#
# spec file for package realtek-r8169
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           r8125
Version:        9.013.02
Release:        5.15.159
Summary:        Realtek 8125 2.5Gigabit ethernet support
License:        GPL-2.0
Group:          System/Kernel
Source0:        %{name}-%{version}.tar.bz2
Source1:        %name-preamble

%kernel_module_package -p %name-preamble

%description
This package contains the kernel module providing support for 
RealTek RTL8125 2.5Gigabit Ethernet controllers with PCI-Express 
interface.


%prep
%setup -q

echo "%{name}.ko" > Module.supported
set -- *
mkdir source
mv "$@" source/
mkdir obj

%build
for flavor in %{flavors_to_build}; do
        rm -rf obj/$flavor
        cp -r source obj/$flavor
        make -C %{kernel_source $flavor} modules \
        M=$PWD/obj/${flavor}/src
done

%install
export INSTALL_MOD_PATH=%{buildroot}/usr
export INSTALL_MOD_DIR=updates
for flavor in %{flavors_to_build}; do
        make -C %{kernel_source $flavor} modules_install \
         M=$PWD/obj/${flavor}/src
done

%changelog