#
# spec file for package perl-HTML-Formatter
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: perl-HTML-Formatter
Version: 2.16
Release: 0
%define cpan_name HTML-Formatter
Summary: Base class for HTML formatters
License: Artistic-1.0 or GPL-1.0+
Group: Development/Libraries/Perl
Url: http://search.cpan.org/dist/HTML-Formatter/
Source0: HTML-Formatter-2.16.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(File::Slurper)
BuildRequires: perl(Font::Metrics::Courier)
BuildRequires: perl(Font::Metrics::CourierBold)
BuildRequires: perl(Font::Metrics::CourierBoldOblique)
BuildRequires: perl(Font::Metrics::CourierOblique)
BuildRequires: perl(Font::Metrics::Helvetica)
BuildRequires: perl(Font::Metrics::HelveticaBold)
BuildRequires: perl(Font::Metrics::HelveticaBoldOblique)
BuildRequires: perl(Font::Metrics::HelveticaOblique)
BuildRequires: perl(Font::Metrics::TimesBold)
BuildRequires: perl(Font::Metrics::TimesBoldItalic)
BuildRequires: perl(Font::Metrics::TimesItalic)
BuildRequires: perl(Font::Metrics::TimesRoman)
BuildRequires: perl(HTML::Element) >= 3.15
BuildRequires: perl(HTML::TreeBuilder)
BuildRequires: perl(Test::More) >= 0.96
BuildRequires: perl(Test::Warnings)
BuildRequires: perl(parent)
Requires: perl(Font::Metrics::Courier)
Requires: perl(Font::Metrics::CourierBold)
Requires: perl(Font::Metrics::CourierBoldOblique)
Requires: perl(Font::Metrics::CourierOblique)
Requires: perl(Font::Metrics::Helvetica)
Requires: perl(Font::Metrics::HelveticaBold)
Requires: perl(Font::Metrics::HelveticaBoldOblique)
Requires: perl(Font::Metrics::HelveticaOblique)
Requires: perl(Font::Metrics::TimesBold)
Requires: perl(Font::Metrics::TimesBoldItalic)
Requires: perl(Font::Metrics::TimesItalic)
Requires: perl(Font::Metrics::TimesRoman)
Requires: perl(HTML::Element) >= 3.15
Requires: perl(HTML::TreeBuilder)
Requires: perl(parent)
%{perl_requires}
%description
HTML::Formatter is a base class for classes that take HTML and format it to
some output format. When you take an object of such a base class and call
'$formatter-'format( $tree )> with an the HTML::TreeBuilder manpage (or the
HTML::Element manpage) object, they return the appropriately formatted
string for the input HTML.
HTML formatters are able to format a HTML syntax tree into various
printable formats. Different formatters produce output for different output
media. Common for all formatters are that they will return the formatted
output when the format() method is called. The format() method takes a
HTML::Element object (usually the HTML::TreeBuilder root object) as
parameter.
The distribution name has been changed to 'HTML-Formatter' as detailed in
the DISTRIBUTION NAME manpage
%prep
%setup -q -n %{cpan_name}-%{version}
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}
%check
%{__make} test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes LICENSE README
%changelog