#
# spec file for package python-xhtml2pdf
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-xhtml2pdf
Version:        0.1b1
Release:        1.2
Summary:        PDF Generator Using HTML and CSS
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            http://www.xhtml2pdf.com/
Source:         http://pypi.python.org/packages/source/x/xhtml2pdf/xhtml2pdf-%{version}.tar.gz
# PATCH-FIX-OPENSUSE no_optimize.patch - Don't generate .pyo files during build
Patch0:         no_optimize.patch
BuildRequires:  python-devel
BuildRequires:  python-setuptools
Requires:       python-html5lib
Requires:       python-pillow
Requires:       python-pypdf
Requires:       python-reportlab
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
xhtml2pdf is a html2pdf converter using the ReportLab Toolkit, the HTML5lib and
pyPdf. It supports HTML 5 and CSS 2.1 (and some of CSS 3). It is completely
written in pure Python so it is platform independent.

The main benefit of this tool that a user with Web skills like HTML and CSS is
able to generate PDF templates very quickly without learning new technologies.

%prep
%setup -q -n xhtml2pdf-%{version}
%patch0 -p1

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

pushd %{buildroot}%{_bindir}
for p in pisa xhtml2pdf ; do
    mv $p $p-%{py_ver}
    ln -s -f $p-%{py_ver} $p
done
popd

%files
%defattr(-,root,root,-)
%doc LICENSE.txt README.rst
%{python_sitelib}/*
%{_bindir}/pisa
%{_bindir}/xhtml2pdf
%{_bindir}/pisa-%{py_ver}
%{_bindir}/xhtml2pdf-%{py_ver}

%changelog
* Fri Nov 15 2013 p.drouand@gmail.com
- Update to version 0.0.5
  + no changelog available
- Remove useless CFLAGS definition
* Thu Oct 24 2013 speilicke@suse.com
- Require python-setuptools instead of distribute (upstreams merged)
* Wed Dec 12 2012 jfunk@funktronics.ca
- Initial release