#
# spec file for package python-CacheControl
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python3-%{**}}
%define skip_python2 1
%define skip_python36 1
%define skip_python39 1
Name:           python-CacheControl
Version:        0.12.10
Release:        1.3
Summary:        Caching library for Python requests
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://github.com/ionrock/cachecontrol
Source:         https://github.com/ionrock/cachecontrol/archive/v%{version}.tar.gz#/CacheControl-%{version}.tar.gz
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Requires:       python-msgpack >= 0.5.2
Requires:       python-requests
Provides:       python-cachecontrol = %{version}-%{release}
Requires(post): update-alternatives
Requires(postun):update-alternatives
Recommends:     python-lockfile >= 0.9
Suggests:       python-redis >= 2.10.5
BuildArch:      noarch
# SECTION test requirements
BuildRequires:  %{python_module CherryPy}
BuildRequires:  %{python_module lockfile >= 0.9}
BuildRequires:  %{python_module msgpack >= 0.5.2}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module redis >= 2.10.5}
BuildRequires:  %{python_module requests}
# /SECTION
%python_subpackages

%description
CacheControl is a port of the caching algorithms in httplib2 for use with
requests session object.

%prep
%setup -q -n cachecontrol-%{version}
sed -i -e 's/^from mock/from unittest.mock/' -e 's/^import mock/from unittest import mock/' tests/*.py

%build
%python_build

%install
%python_install
%python_clone -a %{buildroot}%{_bindir}/doesitcache
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check
# test_file_cache_recognizes_consumed_file_handle uses httpbin.org directly
%pytest -v -k 'not test_file_cache_recognizes_consumed_file_handle'

%post
%python_install_alternative doesitcache

%postun
%python_uninstall_alternative doesitcache

%files %{python_files}
%license LICENSE.txt
%doc README.rst
%python_alternative %{_bindir}/doesitcache
%{python_sitelib}/cachecontrol
%{python_sitelib}/CacheControl-%{version}*-info

%changelog
* Sat Dec  4 2021 Ben Greiner <code@bnavigator.de>
- Update to v0.12.10
  * Dropped support for Python 2.7, 3.4, 3.5.
  * Reduced memory usage when caching large files.
* Wed May 27 2020 Petr Gajdos <pgajdos@suse.com>
- %%python3_only -> %%python_alternative
* Thu Jan  2 2020 John Vandenberg <jayvdb@gmail.com>
- Drop merged pytest4.patch
- Add explanation of one test failure
- Remove mention of httplib2 from package summary
- Update to v0.12.6
  * Test if cache is None before falling back to DictCache
  * Fixed body in 304 response to etag request
  * Added check for "*" value in Vary header
  * Make v4 cache compatible with msgpack 1.0 in the future
* Fri Nov  1 2019 Tomáš Chvátal <tchvatal@suse.com>
- Add patch to work with new pytest:
  * pytest4.patch
* Wed Sep 18 2019 Tomáš Chvátal <tchvatal@suse.com>
- Restrict pytest to 3.x as newer released do not work with
  this package
* Fri Apr  5 2019 Tomáš Chvátal <tchvatal@suse.com>
- Run tests only under py3 as CherryPy is available only there
* Mon Mar 25 2019 John Vandenberg <jayvdb@gmail.com>
- Activate test suite, with two tests currently failing
- Trim description, removing irrelevant information about httplib2
- Recommend lockfile, as a lightweight dependency needed for FileCache,
  which is a primary use of CacheControl.
* Thu Feb 28 2019 Tomáš Chvátal <tchvatal@suse.com>
- Update to 0.12.5:
  * various test fixes
  * few crasher fixes
* Tue Dec  4 2018 Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
* Fri Mar 23 2018 tbechtold@suse.com
- Initial packaging (version 0.12.4)