#
# spec file for package python-immutables
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define skip_python2 1
%define skip_python36 1
%define skip_python39 1
Name:           python-immutables
Version:        0.15
Release:        2.2
Summary:        Immutable collections for Python
License:        Apache-2.0
URL:            https://github.com/MagicStack/immutables
Source:         https://files.pythonhosted.org/packages/source/i/immutables/immutables-%{version}.tar.gz
# PATCH-FIX-UPSTREAM test_none_collisions-32-bit.patch gh#MagicStack/immutables#69 mcepl@suse.com
# Fix test_none_collisions on 32-bit systems
Patch0:         test_none_collisions-32-bit.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
%python_subpackages

%description
Immutable collections for Python.

%prep
%autosetup -p1 -n immutables-%{version}

sed -i 's/\.system//' setup.py

%build
export CFLAGS="%{optflags}"
%python_build

%install
%python_install
%{python_expand rm %{buildroot}%{$python_sitearch}/immutables/*.[ch]
%fdupes %{buildroot}%{$python_sitearch}
}

%check
%pyunittest discover -v

%files %{python_files}
%doc README.rst
%license LICENSE
%{python_sitearch}/*

%changelog
* Thu Aug  5 2021 Matej Cepl <mcepl@suse.com>
- Upstream fixed problems with 32bit systems
  (gh#MagicStack/immutables#69) so we have removed
  skip_32bit_tests.patch and added new solution which actually fixes the
  issue: test_none_collisions-32-bit.patch.
* Thu Apr 22 2021 Dirk Müller <dmueller@suse.com>
- update to 0.15
  * python 3.9 support
* Mon Dec  7 2020 Matej Cepl <mcepl@suse.com>
- Add skip_32bit_tests.patch (gh#MagicStack/immutables#53) to skip tests
  which fail on 32bit architectures.
* Tue Oct 13 2020 Dirk Mueller <dmueller@suse.com>
- skip tests that fail on 32bit
* Wed Sep 16 2020 Dirk Mueller <dmueller@suse.com>
- update to 0.14:
  * python 3.8 support
  * Various improvements w.r.t. type annotations & typing
  * Fix pure-Python implementation to accept keyword argument
  * Fix the mutation API to maintain elements count correctly
  * Allow None to be used as key in pure-Python implementation.
- remove py38.patch (upstream)
* Mon Mar  9 2020 Tomáš Chvátal <tchvatal@suse.com>
- Update to 0.11:
  * Python 3.8 fixes
- Add one more py38 patch:
  * py38.patch
* Tue Sep 10 2019 Tomáš Chvátal <tchvatal@suse.com>
- Format with spec-cleaner
* Sun Apr 14 2019 John Vandenberg <jayvdb@gmail.com>
- Initial spec for v0.9