#
# spec file for package python-itsdangerous
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-itsdangerous
Version:        1.1.0
Release:        1.3
Summary:        Various helpers to pass trusted data to untrusted environments and back
License:        BSD-3-Clause
Group:          Development/Languages/Python
URL:            http://github.com/mitsuhiko/itsdangerous
Source:         https://files.pythonhosted.org/packages/source/i/itsdangerous/itsdangerous-%{version}.tar.gz
BuildRequires:  %{python_module freezegun}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildArch:      noarch
%python_subpackages

%description
It's Dangerous
   ... so better sign this

Various helpers to pass data to untrusted environments and to get it back
safe and sound.

This repository provides a module that is a port of the django signing
module.  It's not directly copied but some changes were applied to
make it work better on its own.

Also I plan to add some extra things.  Work in progress.

%prep
%setup -q -n itsdangerous-%{version}

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%check
%pytest tests

%files %{python_files}
%license LICENSE.rst
%doc CHANGES.rst README.rst
%{python_sitelib}/*

%changelog
* Tue Jun 11 2019 Marketa Calabkova <mcalabkova@suse.com>
- update to version 1.1.0
  * Drop support for Python 2.6 and 3.3.
  * Optimize how timestamps are serialized and deserialized.
  * base64_decode raises BadData when it is passed invalid data.
  * More compact JSON dumps for unicode strings.
  * Use the full timestamp rather than an offset, allowing dates
    before 2011. To retain compatibility with signers from previous
    versions, consider using shim from issue #120.
* Tue Dec  4 2018 Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package, but
  keep testsuite passing.
* Tue Apr  4 2017 jmatejek@suse.com
- update for singlespec
* Thu Nov 17 2016 rjschwei@suse.com
- Include in SLE 12 (FATE#320818, bsc#979331)
* Fri Jul 18 2014 toddrme2178@gmail.com
- Update to 0.24
  - Added a `BadHeader` exception that is used for bad headers
    that replaces the old `BadPayload` exception that was reused
    in those cases.
* Tue Sep  3 2013 cfarrell@suse.com
- license update: BSD-3-Clause
  See the LICENSE file
* Mon Sep  2 2013 speilicke@suse.com
- Initial version