#
# spec file for package python-snowballstemmer
#
# Copyright (c) 2019 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-snowballstemmer
Version:        2.0.0
Release:        1.3
Summary:        16 stemmer algorithms
License:        BSD-3-Clause
Group:          Development/Languages/Python
URL:            https://github.com/shibukawa/snowball_py
Source:         https://files.pythonhosted.org/packages/source/s/snowballstemmer/snowballstemmer-%{version}.tar.gz
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildArch:      noarch
%python_subpackages

%description
This package provides 16 stemmer algorithms (15 + Poerter English
stemmer) generated from Snowball algorithms.  It includes following
language algorithms: Danish, Dutch, English (Standard, Porter),
Finnish, French, German, Hungarian, Italian, Norwegian, Portuguese,
Romanian, Russian, Spanish, Swedish, Turkish. This is a pure Python
stemming library. If PyStemmer is available, this module uses it to
accelerate.

%prep
%setup -q -n snowballstemmer-%{version}

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%files %{python_files}
%{python_sitelib}/*
%doc README.rst
%license COPYING

%changelog
* Fri Dec 20 2019 Dirk Mueller <dmueller@suse.com>
- update to 2.0.0:
  * Simplified generated code for ``repeat`` and ``atleast`` commands.
  * Implemented “go grouping” optimisation.
  * Removed caching layer (#114).
  * Enabled building wheels (#115).
  * Updated package README.
* Tue Sep 10 2019 Tomáš Chvátal <tchvatal@suse.com>
- Update to 1.9.1:
  * provide license file in the tarball
* Tue Aug 27 2019 Jan Engelhardt <jengelh@inai.de>
- Avoid self-reference in summary.
* Fri Aug  2 2019 pgajdos@suse.com
- version update to 1.9.0
  * no upstream change log
  * relicensed to BSD-3-Clause, se README.rst
- added sources
  https://github.com/snowballstem/snowball/issues/102
  + COPYING
* Tue Dec  4 2018 Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
* Thu Jun  1 2017 dmueller@suse.com
- update to 1.2.1:
  * fix syntax error
* Wed Apr  5 2017 tbechtold@suse.com
- Fix python_module macro definition
* Mon Dec 19 2016 jmatejek@suse.com
- update for multipython build
* Thu Apr 23 2015 mcihar@suse.cz
- Compatibility with SLE11
* Thu Apr  9 2015 termim@gmail.com
- copied from python3-snowballstemmer
* Sun Mar 15 2015 arun@gmx.de
- initial version