#
# spec file
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define prjname      openexr
%define flavor   %{nil}
%if "%{flavor}" == ""
%define flavor   openexr
%endif

# perhaps you want to build against corresponding ilmbase build
%define asan_build  0
%define debug_build 0
%define sonum 25
%global so_suffix -2_5
Name:           %{flavor}
Version:        2.5.6
Release:        1.1
%if "%{flavor}" == "openexr"
Summary:        Utilities for working with HDR images in OpenEXR format
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++
%endif
%if "%{flavor}" == "ilmbase"
Summary:        Base library for ILM software (OpenEXR)
License:        BSD-3-Clause
Group:          Development/Libraries/C and C++
%endif
URL:            http://www.openexr.com/
Source0:        https://github.com/openexr/openexr/archive/v%{version}.tar.gz
Source2:        baselibs.conf
Patch1:         0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch
# CVE-2021-3598 [bsc#1187310], Heap buffer overflow in Imf_3_1:CharPtrIO:readChars
Patch2:         openexr-CVE-2021-3598.patch
# CVE-2021-3605 [bsc#1187395], Heap buffer overflow in the rleUncompress function
Patch3:         openexr-CVE-2021-3605.patch
BuildRequires:  cmake
BuildRequires:  gcc-c++
BuildRequires:  pkgconfig
%if "%{flavor}" == "openexr"
BuildRequires:  fltk-devel
BuildRequires:  freeglut-devel
BuildRequires:  pkgconfig(IlmBase) == %{version}
BuildRequires:  pkgconfig(zlib)
%endif
%if "%{flavor}" == "ilmbase"
BuildRequires:  libtool
%endif
%if "%{flavor}" == "openexr"
Obsoletes:      OpenEXR <= 1.6.1
Provides:       OpenEXR = %{version}
%endif
%if "%{flavor}" == "ilmbase"
Obsoletes:      IlmBase <= 1.0.1
Provides:       IlmBase = %{version}
%endif
%if %{asan_build} || %{debug_build}
BuildRequires:  ilmbase-debugsource
BuildRequires:  libHalf%{so_suffix}-%{sonum}-debuginfo
BuildRequires:  libIex%{so_suffix}-%{sonum}-debuginfo
BuildRequires:  libIexMath%{so_suffix}-%{sonum}-debuginfo
BuildRequires:  libIlmThread%{so_suffix}-%{sonum}-debuginfo
BuildRequires:  libImath%{so_suffix}-%{sonum}-debuginfo
%endif

%if "%{flavor}" == "openexr"

%description
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications. This package
contains a set of utilities to work with this format.

* exrheader, a utility for dumping header information
* exrstdattr, a utility for modifying OpenEXR standard attributes
* exrmaketiled, for generating tiled and rip/mipmapped images
* exrenvmap, for creating OpenEXR environment maps
* exrmakepreview, for creating preview images for OpenEXR files
* exr2aces, converter to ACES format
* exrmultiview, combine two or more images into one multi-view

%package -n libIlmImf%{so_suffix}-%{sonum}
Summary:        Library to Handle EXR Pictures in 16-Bit Floating-Point Format
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libIlmImf%{so_suffix}-%{sonum}
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

This package contains shared library libIlmImf

%package -n libIlmImfUtil%{so_suffix}-%{sonum}
Summary:        Library to simplify development of OpenEXR utilities
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libIlmImfUtil%{so_suffix}-%{sonum}
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

This package contains shared library libIlmImfUtil

%package devel
Summary:        Development files for the 16-bit FP EXR picture handling library
License:        BSD-3-Clause AND GPL-2.0-or-later
Group:          Development/Libraries/C and C++
Requires:       ilmbase-devel >= 2.3.0
Requires:       libIlmImf%{so_suffix}-%{sonum} = %{version}
Requires:       libIlmImfUtil%{so_suffix}-%{sonum} = %{version}
Requires:       pkgconfig
Requires:       pkgconfig(zlib)
Obsoletes:      OpenEXR-devel <= 1.6.1
Provides:       OpenEXR-devel = %{version}
Obsoletes:      libopenexr-devel <= 1.7.0
Provides:       libopenexr-devel = %{version}

%description devel
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

This package contains header files.

%package doc
Summary:        Documentation for the 16-bit FP EXR picture handling library
License:        BSD-3-Clause
Group:          Documentation/Other
Obsoletes:      OpenEXR-doc <= 1.6.1
Provides:       OpenEXR-doc = %{version}

%description doc
OpenEXR is a high dynamic-range (HDR) image file format developed by
Industrial Light & Magic for use in computer imaging applications.

This package contains documentation.

%endif

%if "%{flavor}" == "ilmbase"

%description
Base library for Industrial Light & Magic software (OpenEXR).

* Half is a class that encapsulates our 16-bit floating-point
   format.

* IlmThread is a thread abstraction library for use with OpenEXR and
   other software packages.  It currently supports pthreads and
   Windows threads.

* Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices,
   quaternions and other useful 2D and 3D math functions.

* Iex is an exception-handling library.

%package devel
Summary:        Base library for ILM software (OpenEXR)
# Renamed to libilmbase6 to met the Shared Library Policy
License:        BSD-3-Clause AND GPL-2.0-or-later
Group:          Development/Libraries/C and C++
Requires:       libHalf%{so_suffix}-%{sonum}
Requires:       libIex%{so_suffix}-%{sonum}
Requires:       libIexMath%{so_suffix}-%{sonum}
Requires:       libIlmThread%{so_suffix}-%{sonum}
Requires:       libImath%{so_suffix}-%{sonum}
Requires:       libstdc++-devel

%description devel
Devel files for ilmbase
Base library for Industrial Light & Magic software (OpenEXR).

%package -n libHalf%{so_suffix}-%{sonum}
Summary:        16-bit floating-point encapsulation class for OpenEXR
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libHalf%{so_suffix}-%{sonum}
%{summary}.

%package -n libIexMath%{so_suffix}-%{sonum}
Summary:        Exception-based vector/matrix library for OpenEXR
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libIexMath%{so_suffix}-%{sonum}
%{summary}.

%package -n libIex%{so_suffix}-%{sonum}
Summary:        Exception handling library for OpenEXR
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libIex%{so_suffix}-%{sonum}
%{summary}.

%package -n libIlmThread%{so_suffix}-%{sonum}
Summary:        Thread abstraction library for OpenEXR
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libIlmThread%{so_suffix}-%{sonum}
%{summary}.

%package -n libImath%{so_suffix}-%{sonum}
Summary:        Vector/matrix library for OpenEXR
License:        BSD-3-Clause
Group:          System/Libraries

%description -n libImath%{so_suffix}-%{sonum}
%{summary}.

%endif

%prep
%setup -q -n %{prjname}-%{version}
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%if "%{flavor}" == "openexr"
pushd OpenEXR
export PTHREAD_LIBS="-lpthread"
%if %{debug_build}
export CXXFLAGS="%{optflags} -O0"
%endif
%cmake \
  -DCMAKE_INSTALL_DOCDIR="%{_docdir}/%{name}"
%if %{asan_build}
vmemlimit=$(ulimit -v)
if [ $vmemlimit != unlimited ]; then
  echo "ulimit -v has to be unlimited (currently $vmemlimit) to run ASAN build"
  exit 1
fi
for i in $(find -name Makefile); do
  sed -i -e 's/\(^CXXFLAGS.*\)/\1 -fsanitize=address/' \
         -e 's/\(^LIBS =.*\)/\1 -lasan/' \
         $i
done
%endif
%cmake_build
popd
%endif

%if "%{flavor}" == "ilmbase"
pushd IlmBase
%cmake
%if %{asan_build}
vmemlimit=$(ulimit -v)
if [ $vmemlimit != unlimited ]; then
  echo "ulimit -v has to be unlimited (currently $vmemlimit) to run ASAN build"
  exit 1
fi
for i in $(find -name Makefile); do
  sed -i -e 's/\(^CXXFLAGS.*\)/\1 -fsanitize=address/' \
         -e 's/\(^LIBS =.*\)/\1 -lasan/' \
         $i
done
%endif
make %{?_smp_mflags}
popd
%endif

%install
%if "%{flavor}" == "openexr"
pushd OpenEXR
%cmake_install
popd
%endif

%if "%{flavor}" == "ilmbase"
pushd IlmBase
%cmake_install
popd
%endif

%check
%if "%{flavor}" == "openexr"
%ifnarch i586 ppc ppc64 s390 s390x
pushd OpenEXR
export LD_LIBRARY_PATH="%{buildroot}/%{_libdir}"
# tests can take longer than the default timeout of 25 minutes
%if 0%{?suse_version} < 1550
# HACK - older versions of the ctest macro do not allow passing additional parameters
%global __ctest %{__ctest} --timeout 3600
%ctest
%else
%ctest --timeout 3600
%endif
popd
%endif
%endif

%if "%{flavor}" == "ilmbase"
# https://github.com/openexr/openexr/issues/570
%ifnarch i586
pushd IlmBase
export LD_LIBRARY_PATH="$PWD/build/Imath:$PWD/build/Iex:$PWD/build/Half:$LD_LIBRARY_PATH"
%ctest
popd
%endif
%endif

%if "%{flavor}" == "openexr"
%post -n libIlmImf%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libIlmImf%{so_suffix}-%{sonum} -p /sbin/ldconfig

%post -n libIlmImfUtil%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libIlmImfUtil%{so_suffix}-%{sonum} -p /sbin/ldconfig
%endif

%if "%{flavor}" == "ilmbase"
%post -n libHalf%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libHalf%{so_suffix}-%{sonum} -p /sbin/ldconfig

%post -n libIexMath%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libIexMath%{so_suffix}-%{sonum} -p /sbin/ldconfig

%post -n libIex%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libIex%{so_suffix}-%{sonum} -p /sbin/ldconfig

%post -n libIlmThread%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libIlmThread%{so_suffix}-%{sonum} -p /sbin/ldconfig

%post -n libImath%{so_suffix}-%{sonum} -p /sbin/ldconfig
%postun -n libImath%{so_suffix}-%{sonum} -p /sbin/ldconfig
%endif

%if "%{flavor}" == "openexr"
%files
%license LICENSE.md
%doc CHANGES.md CODE_OF_CONDUCT.md CODEOWNERS CONTRIBUTING.md CONTRIBUTORS.md README.md SECURITY.md
%{_bindir}/exrenvmap
%{_bindir}/exrheader
%{_bindir}/exrmakepreview
%{_bindir}/exrmaketiled
%{_bindir}/exrstdattr
%{_bindir}/exrmultiview
%{_bindir}/exrmultipart
%{_bindir}/exr2aces

%files devel
%{_includedir}/OpenEXR
%{_libdir}/libIlmImf.so
%{_libdir}/libIlmImf%{so_suffix}.so
%{_libdir}/libIlmImfUtil.so
%{_libdir}/libIlmImfUtil%{so_suffix}.so
%{_libdir}/pkgconfig/OpenEXR.pc
%dir %{_libdir}/cmake/OpenEXR
%{_libdir}/cmake/OpenEXR/*.cmake

%files doc
%{_docdir}/%{name}
%exclude %{_docdir}/%{name}/{CHANGES.md,CODE_OF_CONDUCT.md,CODEOWNERS,CONTRIBUTING.md,CONTRIBUTORS.md,README.md,SECURITY.md}

%files -n libIlmImf%{so_suffix}-%{sonum}
%license LICENSE.md
%{_libdir}/libIlmImf-*.so.*

%files -n libIlmImfUtil%{so_suffix}-%{sonum}
%license LICENSE.md
%{_libdir}/libIlmImfUtil-*.so.*
%endif

%if "%{flavor}" == "ilmbase"
%files devel
%doc CHANGES.md CODE_OF_CONDUCT.md CODEOWNERS CONTRIBUTING.md CONTRIBUTORS.md README.md SECURITY.md
%license LICENSE.md
%{_includedir}/OpenEXR
%{_libdir}/libHalf.so
%{_libdir}/libHalf%{so_suffix}.so
%{_libdir}/libIex.so
%{_libdir}/libIex%{so_suffix}.so
%{_libdir}/libImath.so
%{_libdir}/libImath%{so_suffix}.so
%{_libdir}/libIlmThread.so
%{_libdir}/libIlmThread%{so_suffix}.so
%{_libdir}/libIexMath.so
%{_libdir}/libIexMath%{so_suffix}.so
%{_libdir}/pkgconfig/IlmBase.pc
%dir %{_libdir}/cmake/IlmBase/
%{_libdir}/cmake/IlmBase/*.cmake

%files -n libHalf%{so_suffix}-%{sonum}
%{_libdir}/libHalf%{so_suffix}.so.*

%files -n libIexMath%{so_suffix}-%{sonum}
%{_libdir}/libIexMath%{so_suffix}.so.*

%files -n libIex%{so_suffix}-%{sonum}
%{_libdir}/libIex%{so_suffix}.so.*

%files -n libIlmThread%{so_suffix}-%{sonum}
%{_libdir}/libIlmThread%{so_suffix}.so.*

%files -n libImath%{so_suffix}-%{sonum}
%{_libdir}/libImath%{so_suffix}.so.*
%endif

%changelog
* Wed Jun 16 2021 pgajdos@suse.com
- security update
- added patches
  fix CVE-2021-3605 [bsc#1187395], Heap buffer overflow in the rleUncompress function
  + openexr-CVE-2021-3605.patch
* Tue Jun 15 2021 pgajdos@suse.com
- security update
- added patches
  fix CVE-2021-3598 [bsc#1187310], Heap buffer overflow in Imf_3_1:CharPtrIO:readChars
  + openexr-CVE-2021-3598.patch
* Tue Jun 15 2021 pgajdos@suse.com
- version update to 2.5.6
  * [#1013](https://github.com/AcademySoftwareFoundation/openexr/pull/1013)
  Fixed regression in Imath::succf() and Imath::predf() when negative values are given
* Wed Mar 31 2021 pgajdos@suse.com
- version update to 2.5.5
  Patch release with various bug/sanitizer/security fixes, primarily
  related to reading corrupted input files, but also a fix for universal
  build support on macOS.
- see CHANGES.md for details
* Thu Jan  7 2021 pgajdos@suse.com
- merge also baselibs.conf
- modified sources
  %% baselibs.conf
* Tue Jan  5 2021 pgajdos@suse.com
- merge ilmbase and openexr source packages into one _multibuild
- added sources
  + _multibuild
* Tue Jan  5 2021 pgajdos@suse.com
- version update to 2.5.4
  * Patch release with various bug/sanitizer/security fixes, primarily
    related to reading corrupted input files.
* Wed Sep 30 2020 pgajdos@suse.com
- version update to 2.5.3
  * Various sanitizer/fuzz-identified issues related to handling of invalid input
  * Fixes to misc compiler warnings
  * Cmake fix for building on arm64 macOS (#772)
  * Read performance optimization (#782)
  * Fix for building on non-glibc (#798)
  * Fixes to tests
* Tue Sep 15 2020 ro@suse.de
- Disable testsuite also on s390/s390x, probably will not pass
  on any bigendian platform in current state
* Thu Jul 16 2020 Andreas Schwab <schwab@suse.de>
- Disable testsuite also on ppc
* Sun Jul  5 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Fix 0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch
  so pkgconfig file has no duplicate prefix.
- Run test suite also on all other archs but i586 and ppc64(be)
* Mon Jun 29 2020 pgajdos@suse.com
- version update to 2.5.2
  2.5.2
  * Invalid input could cause a heap-use-after-free error in DeepScanLineInputFile::DeepScanLineInputFile()
  * Invalid chunkCount attributes could cause heap buffer overflow in getChunkOffsetTableSize()
  * Invalid tiled input file could cause invalid memory access TiledInputFile::TiledInputFile()
  * OpenEXRConfig.h now correctly sets OPENEXR_PACKAGE_STRING to "OpenEXR" (rather than "IlmBase")
  2.5.1
  * A patch release that corrects the SO version for the v2.5 release,
    which missed getting bumped in v2.5.0.
  * This release also fixes an improper failure in IlmImfTest when running
    on ARMv7 and AAarch64.
  2.5.0
  * No more build-time header generation: toFloat.h, eLut.h,
    b44ExpLogTable.h, and dwaLookups.h are now ordinary header files, no
    longer generated on the fly.
  * New StdISSTream class, an "input" stringstream version of StdOSStream
  * New Matrix22 class in Imath
  * Chromaticity comparison operator now includes white (formerly ignored)
  * Various cmake fixes
  * Bug fixes for various memory leaks
  * Bug fixes for various invalid memory accesses
  * New checks to detect damaged input files
  * OpenEXR_Viewers has been deprecated, removed from the top-level
    cmake build and documentation.
- modified patches
  %% 0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch (refreshed)
- modified sources
  %% baselibs.conf
* Thu Apr 16 2020 pgajdos@suse.com
- version update to 2.4.1
  * Various fixes for memory leaks and invalid memory accesses
  * Various fixes for integer overflow with large images.
  * Various cmake fixes for build/install of python modules.
  * ImfMisc.h is no longer installed, since it's a private header.
- deleted patches
  - Fix-the-symlinks-creation.patch (upstreamed)
* Mon Feb 10 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Fix relative paths in generated pkgconfig files:
  0001-Use-absolute-CMAKE_INSTALL_FULL_LIBDIR-for-libdir-in.patch
* Sun Nov 24 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
- Fix build with older cmake package (Leap 15.0 up to 15.2), the
  included ctest macro does not accept extra parameters.
* Thu Nov 14 2019 Christophe Giboudeaux <christophe@krop.fr>
- Add Fix-the-symlinks-creation.patch to fix the symlinks creation.
* Mon Oct  7 2019 pgajdos@suse.com
- fix OpenEXR.pc
* Fri Oct  4 2019 pgajdos@suse.com
- increase timeout for IlmImf test
* Thu Sep 26 2019 pgajdos@suse.com
- version update to 2.4.0
  * Completely re-written CMake configuration files
  * Improved support for building on Windows, via CMake
  * Improved support for building on macOS, via CMake
  * All code compiles without warnings on gcc, clang, msvc
  * Cleanup of license and copyright notices
  * floating-point exception handling is disabled by default
  * New Slice::Make method to reliably compute base pointer for a slice.
  * Miscellaneous bug fixes
  * CVE-2018-18444 Issue #351 Out of Memory
  * CVE-2018-18443 Issue #350 heap-buffer-overflow
- upstream does not provide gpg signature anymore
  https://github.com/openexr/openexr/issues/565
- modified sources
  %% baselibs.conf
- deleted patches
  - openexr-CVE-2017-14988.patch (upstreamed)
  - openexr-CVE-2017-9111,9113,9115.patch (upstreamed)
  - openexr-CVE-2018-18444.patch (upstreamed)
- deleted sources
  - openexr-2.3.0.tar.gz.sig (not needed)
  - openexr.keyring (not needed)
* Fri Sep 20 2019 pgajdos@suse.com
- testsuite only for x86_64 [bsc#1146648]
* Wed Aug 21 2019 Martin Pluskal <mpluskal@suse.com>
- Enable tests on architectures with enough memory - boo#1146648
  * disable imffuzztest as it takes to much resources
* Mon Jul 15 2019 pgajdos@suse.com
- security update
- added patches
  CVE-2017-14988 [bsc#1061305]
  + openexr-CVE-2017-14988.patch
* Fri Jun 14 2019 pgajdos@suse.com
- security update
- added patches
  CVE-2017-9111 [bsc#1040109], CVE-2017-9113 [bsc#1040113], CVE-2017-9115 [bsc#1040115]
  + openexr-CVE-2017-9111,9113,9115.patch
* Wed Nov  7 2018 Jan Engelhardt <jengelh@inai.de>
- Codify new ilmbase requirements.
* Wed Nov  7 2018 Petr Gajdos <pgajdos@suse.com>
- security update
  * CVE-2018-18444 [bsc#1113455]
    + openexr-CVE-2018-18444.patch
* Tue Nov  6 2018 Petr Gajdos <pgajdos@suse.com>
- asan_build: build ASAN included
- debug_build: build more suitable for debugging
* Mon Nov  5 2018 Jan Engelhardt <jengelh@inai.de>
- Remove useless --with-pic.
- Adjust RPM groups and repair sentence structure.
* Mon Nov  5 2018 Petr Gajdos <pgajdos@suse.com>
- updated to 2.3.0
  * ThreadPool overhead improvements, enable custom thread pool
    to be registered via ThreadPoolProvider class
  * Fixes to enable custom namespaces for Iex, Imf
  * Improve read performance for deep/zipped data, and
    SIMD-accelerated uncompress support
  * Added rawPixelDataToBuffer() function for access to
    compressed scanlines
  * Iex::BaseExc no longer derived from std::string.
  * Imath throw() specifiers removed
  * Initial Support for Python 3
  * removed patch
* Mon Jan 15 2018 avindra@opensuse.org
- Update to 2.2.1
  * Fix reported OpenEXR security vulnerabilities: CVE-2017-9110,
    CVE-2017-9111, CVE-2017-9112, CVE-2017-9113, CVE-2017-9114,
    CVE-2017-9115 and CVE-2017-9116
- pgajdos@suse.com: but really seem to fix only:
  CVE-2017-9110 [bsc#1040107], CVE-2017-9114 [bsc#1040114],
  CVE-2017-9116 [bsc#1040116], CVE-2017-12596 [bsc#1052522]; for
  the rest of issues see [bsc#1040109], [bsc#1040112],
  [bsc#1040113], [bsc#1040114], [bsc#1040115], and [bsc#1061305]
* Wed Jul 12 2017 tchvatal@suse.com
- Cleanup a bit with spec-cleaner
* Thu Jan 29 2015 mlin@suse.com
- Update to 2.2.0
  * DreamWorks Lossy Compression A new high quality, high performance lossy
    compression codec contributed by DreamWorks Animation. This codec allows
    control over variable lossiness to balance visual quality and file size.
    This contribution also includes performance improvements that speed up
    the PIZ codec.
  * IlmImfUtil A new library intended to aid in development of image file
    manipulation utilities that support the many types of OpenEXR images.
  * This release also includes improvements to cross-platform build support
    using CMake.
- Bumped the soname, and now we have libIlmImf and libIlmImfUtil
- Removed openexr-2.1.0-headers.patch
- Updated openexr.keyring from the savannah project page.
* Tue Aug 26 2014 fcrozat@suse.com
- Add obsoletes to baselibs.conf.
* Thu Apr 24 2014 dmueller@suse.com
- remove dependency on gpg-offline (blocks rebuilds and
  tarball integrity is checked by source-validator anyway)
* Thu Nov 28 2013 toganm@opensuse.org
- add openexr-2.1.0-headers.patch to install
  ImfDeepImageStateAttribute.h header too
* Wed Nov 27 2013 mvyskocil@suse.com
- update to 2.1.0
  This release includes a refactoring of the optimised read paths for RGBA
  data, optimisations for some of the python bindings to Imath, improvements to
  the cmake build environment as well as additional documentation describing
  deep data in more detail.
- make tests conditional, enable fuzz test and huge test
* Mon Jul 15 2013 mvyskocil@suse.com
- update to 2.0.1
  This is a maintenance push that predominantly addresses edge case
  failures in the optimisation code paths by temporarily disabling the
  feature. For more details, please refer to the
  /usr/share/doc/packages/openexr/ChangeLog
- add gpg-offline based verification
* Sat Apr 20 2013 coolo@suse.com
- fix library deps
* Fri Apr 12 2013 mvyskocil@suse.com
- update to 2.0.0
  * Deep Data support - Pixels can now store a variable-length list of samples.
  The main rationale behind deep images is to enable the storage of multiple
  values at different depths for each pixel. OpenEXR 2.0 supports both
  hard-surface and volumetric representations for Deep Compositing workflows.
  * Multi-part Image Files - With OpenEXR 2.0, files can now contain a number
  of separate, but related, data parts in one file. Access to any part is
  independent of the others, pixels from parts that are not required in the
  current operation don't need to be accessed, resulting in quicker read
  times when accessing only a subset of channels. The multipart interface
  also incorporates support for Stereo images where views are stored in
  separate parts. This makes stereo OpenEXR 2.0 files significantly faster to
  work with than the previous multiview support in OpenEXR.
  * Optimized pixel reading - decoding RGB(A) scanline images has been
  accelerated on SSE processors providing a significant speedup when reading
  both old and new format images, including multipart and multiview files.
  * Namespacing - The library introduces versioned namespaces to avoid
  conflicts between packages compiled with different versions of the library.
- obsoleted
    openexr-suse-docdir.patch (moved in install phase)
    openexr-disable-tests.patch
* Thu Sep 27 2012 cfarrell@suse.com
- license update: BSD-3-Clause
  No GPL licensed files found in the package
* Thu Sep 27 2012 idonmez@suse.com
- Update baselibs.conf
* Thu Aug  2 2012 mvyskocil@suse.cz
- Update to 1.7.1
  * Updated the .so verison to 7.
  * obsoletes openexr-includes.patch
- require new ilmbase-devel for build
- rename libopenexr-devel to openexr devel to be compatible
  with renamed ilmbase package
* Tue Apr 24 2012 mvyskocil@suse.cz
- disable the test at all, as running them in OBS seems not to be
  reliable
* Sun Jan 29 2012 jengelh@medozas.de
- Remove redundant tags/sections per specfile guideline suggestions
* Mon Oct 31 2011 mvyskocil@suse.cz
- openexr-disable-tests.patch - disable broken tests prevents a build
  in Factory
* Wed Jul 27 2011 dmueller@suse.de
- remove explicit libdrm buildrequires
* Tue Mar  8 2011 jengelh@medozas.de
- Use %%_smp_mflags for parallel build
* Mon Aug  9 2010 mvyskocil@suse.cz
- Update to 1.7.0 - bugfix release, multiviewer support
  * obsoletes CVE-2009-1720 support
  * built with --enable-larget-stack and test
- Renammed to be more comfortable with Shared Library policy
  * openexr - main (source package) contains tools in bindir, it provides and
    obsoletes the old OpenEXR symbol
  * libIlmImf6 - contains the openexr library
  * libopenexr-devel - contains the headers, Provides and Obsoletes the
    OpenEXR-devel symbol
  * openexr-doc - documentation
* Fri Dec 18 2009 jengelh@medozas.de
- add baselibs.conf as a source
* Tue Aug  4 2009 mvyskocil@suse.cz
- fixed bnc#527539:  VUL-0: OpenEXR: [ MDVSA-2009:190 ] OpenEXR
  used patches from Mandriva
  * CVE-2009-1720
  * CVE-2009-1721
* Mon Mar  2 2009 crrodriguez@suse.de
- save 6.7MB by removing static libraries and "la" files
* Wed Dec 10 2008 olh@suse.de
- use Obsoletes: -XXbit only for ppc64 to help solver during distupgrade
  (bnc#437293)
* Thu Oct 30 2008 olh@suse.de
- obsolete old -XXbit packages (bnc#437293)
* Thu Apr 10 2008 ro@suse.de
- added baselibs.conf file to build xxbit packages
  for multilib support
* Wed Oct 31 2007 mvyskocil@suse.cz
- update to 1.6.1
- fix buid, add docu subpackage with documentation and examples
* Sat May 19 2007 stbinner@suse.de
- fix linking of new IlmThread lib versus libpthread
* Mon May 14 2007 ltinkl@suse.cz
- update to 1.4.6
- fix build, fix packaging examples and doc
- added missing Requires
* Tue Jan 16 2007 meissner@suse.de
- fixed RPM_OPT_FLAGS
* Mon Jun 12 2006 dmueller@suse.de
- fix shared lib dependencies
- fix installed headers
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Nov  7 2005 sndirsch@suse.de
- make use of mesa-devel-packages macro in neededforbuild
* Wed Nov  2 2005 dmueller@suse.de
- don't build as root
* Wed May 25 2005 adrian@suse.de
- update to version 1.2.2
* Mon May 23 2005 schwab@suse.de
- Fix missing declaration.
* Thu Jan 13 2005 ro@suse.de
- try to fix docu installation
* Mon Jun 28 2004 adrian@suse.de
- initial package of version 1.2.1