Einleitung

Imond auf dem Router beherrscht zwei verschiedene Benutzermodi: den User- und den Adminmodus. Im Adminmodus sind alle Steuerelemente des Imonc aktiviert. Die Konfigurationsvariablen IMOND_ENABLE, IMOND_DIAL, IMOND_ROUTE, IMOND_REBOOT beeinflussen den Usermodus, d.h. der Inhalt der Variablen steuert, ob die entsprechende Funktion zur Verfügung steht. Sind alle genannten Variablen auf 'no' gesetzt, bedeutet dies für die Überblick-Seite, dass alle Buttons bis auf den Beenden- und den Admin-Button deaktiviert sind. Die Entscheidung, ob der User- oder Admin-Modus benutzt wird, wird anhand des per Startparameter übermittelten Passwortes getroffen. Über den Admin-Button in der Statusleiste kann jederzeit bei Eingabe des Admin-Passwortes vom User- zum Admin-Modus gewechselt werden.

Sobald imonc gestartet ist, wird ein zusätzliches Tray-Icon angezeigt, welches den Verbindgungsstatus der vorhandenen Kanäle anzeigt. Die Gestalt des Icons hängt dabei von der installierten Hardware im Router ab. Dabei bedeuten die Farben:

  • Rot: Offline
  • Gelb: Verbindungsaufbau
  • Hellgrün: Online und Traffic auf dem Channel
  • Dunkelgrün: Online und so gut wie kein Traffic auf dem Channel

Um Imonc in den Tray zu minimieren, gibt es die Möglichkeit dieses über den Minimieren-Button zu erledigen. Damit bleibt nur noch das Tray-Icon neben der Uhr übrig. Ein Doppelklick mit der linken Maustaste auf das Tray-Symbol holt das Imonc-Fenster wieder in den Vordergrund. Mit der rechten Maustaste besteht auch die Möglichkeit über das Kontextmenü, die wichtigsten imonc-Kommandos direkt auszuwählen, ohne imonc wieder auf den Bildschirm zu holen.

Viele Eigenschaften (darunter auch alle Spaltenbreiten der StringGrids) speichert Imonc in der Registry, damit Imonc so an die eigenen Bedürfnisse angepasst werden kann. Imonc speichert die Informationen in dem Registry-Schlüssel HKCU\Software\fli4l.

Bestehen trotz intensiven Lesens der Dokumentation noch Probleme in Bezug auf Imonc oder auch des Routers selber, die man z.B. in der Newsgroup posten möchte, ist es sinnvoll, auf der Über-Seite des Imoncs den Punkt System Info auszuwählen und dort den Punkt Support-Infos. Daraufhin wird das root-Passwort abgefragt (nicht das imond-Passwort!). Imonc erstellt dann eine Datei fli4lsup.txt, welche alle wichtigen Informationen bezüglich des Routers und imonc beinhaltet. Relevante Teile dieser Datei können dann dem Support-Formular auf der fli4l-Homepage hinzugefügt werden oder auf Nachfrage in die Newsgroup gepostet werden, so dass deutlich bessere Chancen auf rasche Hilfe bestehen.

Nähere Details betreffend der Entwicklung des Windows-Clients imonc befinden sich auf der Imonc-Homepage unter den Punkten History und Roadmap. Dort kann man sehen, welche neuen Features und Bug-Fixes in der nächsten Version von imonc enthalten sein werden. Ausserdem gibt es dort den neusten imonc, wenn dieser nicht schon in der fli4l-Distribution enthalten ist.


Startparameter

Das Client-Programm benötigt den Namen oder die IP-Adresse des fli4l-Routers. Standardmäßig versucht das Programm, eine Verbindung mit dem Rechner "fli4l" herzustellen. Wenn dieser im DNS korrekt eingetragen ist, sollte es also direkt funktionieren. Ansonsten kann man in der Verknüpfung folgende Parameter übergeben:

  • /Server:IP oder Hostname des Routers (Kurzform: /S:IP oder Hostname)
  • /Password:Passwort (Kurzform: /P:Password)
  • /log Die Logging-Option zum Protokollieren der Kommunikation zwischen imonc und imond. Ist diese Option eingeschaltet, wird beim Beenden von imonc eine Datei imonc.log geschrieben. Diese Datei beinhaltet die gesamte Kommunikation zwischen Router und Client und wird darum sehr groß. Deshalb sollte dieser Parameter nur gesetzt werden, wenn Probleme bestehen.
  • /iport:Portnummer Die Portnummer auf die imond lauscht. Default: 5000
  • /tport:Portnummer Die Portnummer auf die telmond lauscht. Default: 5001
  • /rc:"Command" Das hier angegebene Kommando wird ohne weitere Überprüfung an den Router übertragen und anschliessend imonc beendet. Sollen mehrere Kommandos gleichzeitig ausgeführt werden, müssen diese durch Semikolons getrennt werden. Damit es funktioniert, muss ein gesetztes imond-Passwort mit übergeben werden, da keine Abfrage des Passwortes erfolgt. Die möglichen Kommandos sind beim imond dokumentiert. Zusätzlich zu den dort aufgeführten Befehlen gibt es noch den Befehl timesync. Dieser bewirkt, dass die Uhrzeit des Clients mit der des Routers synchronisiert wird. Der Befehl dialtimesync wird nicht mehr unterstützt da er sich als "dial; timesync" schreiben lässt.
  • /d:"fli4l-Directory" Hiermit kann das fli4l-Directory per Startparameter übergeben werden. Interessant wenn mit mehreren fli4l-Versionen herumspielt wird.
  • /wait Wenn der Hostname nicht aufgelöst werden kann, beendet sich imonc nicht mehr - erneuter Verbindungsaufbau durch Doppelclick auf das TrayIcon.
  • /nostartcheck Dieser schaltet die Überprüfung ab, ob imonc bereits läuft. Nur sinnvoll, wenn mehrere, unterschiedliche fli4l-Router in einem Netz überwacht werden sollen. Bei weiteren Instanzen werden die eingebauten Syslog- und EMail-Funktionalitäten deaktiviert.

Usage (einzutragen in der Verknüpfung):

X:\...imonc.exe [/Server:Host] [/Password:Passwort] [/iport:Portnummer] [/log] [/tport:Portnummer] [/rc:"Command"]

Beispiel mit IP-Adresse:

C:\wintools\imonc /Server:192.168.6.4

oder mit Namen und Password:

C:\wintools\imonc /S:fli4l /P:geheim

oder mit Namen, Password und Routerkommando:

C:\wintools\imonc /S:fli4l /P:geheim /rc:"dialmode manual"


Summary-Seite

Seite Überblick

Der Windows-Client imonc.exe fragt einige imond-Informationen über das LAN ab und bereitet sie im Anzeigefenster auf. Dazu gehören unter anderem:
Local/Remote Date | Windows-/fli4l-Datum und Uhrzeit
Status | Calling/Online/Offline
Verbindung | Telefonnummer des Gegners oder Circuit-Name
Richtung | Zeigt an, ob es sich um eine eingehende oder ausgehende Verbindung handelt
IP | Die IP, die man zugewiesen bekommen hat
IBytes | Empfangene Bytes
OBytes | Gesendete Bytes
Online-Zeit | Aktuelle Online-Zeit
Zeit | Summe aller Online-Zeiten
Kosten-Zeit | Summe Online-Zeiten unter Berücksichtigung des Zeittaktes
Kosten | Berechnete Kosten
Die Daten werden alle 2 Sekunden aktualisiert. Dieses Intervall ist im Konfig-Dialog einstellbar. Im Kontextmenü dieser Übersicht besteht die Möglichkeit für jeden vorhandenen Kanal, mit dem der Router gerade online ist, sowohl die zugewiesene IP in die Zwischenablage zu kopieren, als auch den Kanal gezielt aufzulegen. Letzteres ist für den Fall interessant, dass mehrere unterschiedliche Verbindungen bestehen, z.B. eine um im Internet zu surfen und eine andere zur Firma, und gezielt eine dieser Verbindungen getrennt werden soll.

Ist zusätzlich auf dem fli4l-Router der telmond-Prozess aktiv, kann Imonc zusätzlich Informationen über eingehende Telefonanrufe (nämlich anrufende und angerufene Telefonnummer) anzeigen. Der letzte eingegangene Telefonanruf wird oberhalb der Buttons angezeigt. Ein Protokoll der erhaltenen Telefonanrufe erhält man durch Anzeige der Seite Anrufe.

Mit den fünf Buttons können folgende Kommandos angewählt werden:
Beschriftung | Funktion
Wählen / Auflegen | Wählen bzw. Auflegen
Add link/Rem link | Kanäle bündeln: ja/nein - dieses Feature steht nur im Admin-Mode für ISDN-Kanäle zur Verfügung
Reboot | den Router neu booten
Halt | den Router sauber runterfahren, um ihn anschliessend sicher ausschalten zu können
Beenden | Imonc beenden
Die ersten vier Kommandos können in der Konfigurationsdatei config/base.txt des fli4l-Routers für den User-Modus einzeln ein- und ausgeschaltet werden. Im Admin-Modus sind immer alle aktiviert.

Die Auswahl Dialmode steuert das Wahlverhalten des Routers:
Auto | Der Router baut automatisch eine Verbindung zum Internet auf, wenn eine Anfrage aus dem lokalen Netz eintrifft.
Manuell | Der Benutzer muss selber die Verbindung aufbauen.
Aus | Es ist weder manuell noch automatisch möglich, eine Verbindung aufzubauen. Der Wählen-Button ist deaktiviert.
Bleibt noch anzumerken, dass fli4l standardmäßig selbständig rauswählt, wenn man mit seinem Rechner in's Internet will. Man muss also eigentlich nie den Dial-Button drücken ...

Es besteht auch die Möglichkeit, den Default-Route-Circuit manuell zu wechseln, also das automatische LCR-Routing ein- und auszuschalten. Dafür ist die Auswahlliste "Default Route" vorgesehen. Ausserdem kann man die Hangup-TimeOut-Zeit für ISDN-Circuits jetzt auch über imonc direkt konfigurieren. Dazu dient der Button Bearbeiten neben der Default Route. Einen Überblick über das LCR-Routing findet man auf der Seite Admin/TimeTable. Dort sieht man, welchen Circuit imond zu welcher Zeit automatisch auswählt.


Call-Seite

Seite Anrufe

Die Seite Anrufe wird nur angezeigt, wenn die Variable TELMOND_LOG in der Konfig-Datei config/isdn.txt auf `yes' gesetzt ist, denn sonst wird kein Anruf-Log geführt. Auf dieser Seite werden alle abgespeicherten Telefonanrufe angezeigt, die eingegangen sind, als der Router eingeschaltet war.

Dabei kann umgeschaltet werden zwischen der Ansicht der lokal gespeicherten Anrufe oder nur der auf dem Router gespeicherten Anrufe. Wird bei der Anzeige der auf dem Router gespeicherten Anrufe der Reset-Button gedrückt, wird das Logfile auf dem Router gelöscht.

In der Anruf-Übersicht kann mit der rechten Maustaste auf der Rufnummer oder der eigenen MSN diese ins Telefonbuch übernommen werden, um der Rufnummer bzw. MSN dort einen Namen zuzuweisen, der dann stattdessen angezeigt wird.


Connections-Seite

Seite Verbindungen

Calls-Seite

Auf dieser Seite werden die von Router aufgebauten Verbindungen angezeigt. Somit hat man einen guten Überblick, wie sich der Router bei der automatischen Einwahl ins Internet verhält. Damit diese Seite angezeigt werden kann, muss in der Datei config/base.txt die Variable IMOND_LOG auf `yes' gesetzt werden.

Genauso wie bei der Anruf-Übersicht kann auch hier zwischen den lokal gespeicherten bzw. auf dem Router gespeicherten Verbindungen umgeschaltet werden. In der Ansicht der auf dem Router gespeicherten Verbindungen bewirkt ein Drücken des Reset-Buttons, dass das Logfile auf dem Router gelöscht wird.

Angezeigt werden pro Verbindung

  • Circuitname
  • Startdatum und -zeit
  • Enddatum und -zeit
  • Onlinezeit
  • Abrechnungszeit
  • entstandene Kosten
  • empfangene Zeichen
  • gesendete Zeichen
Die Online-Zeit, die Online-Kosten, die empfangenen und die versendeten Bytes werden unter Tabelle aufsummiert.

Daneben kann auch direkt das Program FliStat von Stefan Böhm gestartet werden. Dieses Programm bietet eine ausführlichere Auswertung der Verbindungsstatistiken als sie Imonc bietet.


Fax-Seite

Seite Faxe

Damit die Seite Faxe angezeigt wird, muss auf dem Router entweder das OPT_MGETTY oder OPT_FAXRCV installiert werden. Diese gibt es auf der fli4l-Homepage unter OPT-Pakete. Auf dieser Seite werden dann alle eingegangenen Faxe aufgelistet. Das Kontextmenü der Übersicht bietet mehrere Möglichkeiten, diese stehen allerdings nur im Admin-Modus zur Verfügung:

  • Es kann ein Fax angezeigt werden. Dazu muss unter Admin/RemoteUpdate der Pfad für das fli4l-Verzeichnis korrekt gesetzt werden, da die Faxe auf dem Router in gepackter Form vorliegen und somit gzip aus dem fli4l-Paket benötigt wird. Alternativ kann gzip.exe und win32gnu.dll auch ins imonc-Verzeichnis kopiert werden. Kann gzip.exe nicht an einer der beiden Stellen gefunden werden, wird stattdessen der Webserver des Routers probiert zu öffnen (direkt mit dem Aufruf des richtigen CGIs).
  • Ein einzelnes Fax kann gelöscht werden. Dabei wird das Fax sowohl lokal als auch auf dem Router gelöscht (sowohl die eigentliche Faxdatei, als auch der Eintrag in den Logdateien).
  • Sämtliche auf dem Router befindlichen Faxe löschen. Damit werden die Faxe und die Logdatei auf dem Router gelöscht. Die Faxe werden nicht aus der lokalen Logdatei gelöscht.

Genauso wie bei der Anruf-Übersicht kann auch hier zwischen den lokal gespeicherten und auf dem Router gespeicherten Faxen umgeschaltet werden.


EMail-Seite

Seite EMails

Diese Seite wird nur angezeigt, wenn im Konfig-Dialog mindestens ein aktiviertes POP3-EMail-Konto eingerichtet worden ist.

Diese Seite dürfte sich eigentlich selber erklären. Hiermit wird der eingebaute EMailChecker beobachtet. Ist die Option "Auch wenn Router offline ist" nicht aktiviert, überprüft der EMailChecker alle EMail-Konten nach EMails, sobald der Router online ist und anschließend im eingestellt Intervall. Ist die genannte Option aktiviert, überprüft der EMailChecker im eingestellten Intervall. Ist der Router gerade online, wird die bestehende Verbindung benutzt. Ist er nicht online, wird eine Verbindung selbständig mit dem ausgewählten Circuit hergestellt, die, sobald alle EMail-Konten abgearbeitet sind, wieder getrennt wird. Damit man diese Option nutzen kann, muss Dialmode auf "auto" stehen.

Sind EMails auf dem POP3-Server vorhanden, wird entweder automatisch der eingestellte EMail-Client gestartet oder ein neues Symbol im Tray neben der Uhr angezeigt, welches als Hint die Anzahl der EMails auf jedem Server liefert. Ein Doppelclick startet dann den eingestellten EMail-Client. Ist ein Fehler bei einem der EMail-Konten aufgetreten, erscheint einerseits ein Hinweis in der EMail-History, andererseits wird das EMail-TrayIcon angezeigt, welches dadurch gekennzeichnet ist, dass die obere rechte Ecke rot gefärbt ist.

In der EMail-Übersicht kann man mit dem Kontextmenü Mails direkt auf dem Server löschen, ohne sie vorher komplett downloaden zu müssen. Dies geschieht, indem mit der rechten Maustaste das Kontextmenü angezeigt wird. Dabei sollte eine Zelle der entsprechenden Zeile markiert sein, wo die zu löschende EMail eingetragen ist. Im Kontextmenü wählt man den einzige Punkt Delete MailMessage aus.


TimeTable-Seite

Seite TimeTable

Es wird eine Übersicht über die verwendeten Circuits, die der Router automatisch per LCR auswählt, angezeigt. Ein Doppelclick auf einen Provider in der Providerübersicht zeigt an, für welche Zeiträume der Circuit in config/isdn.txt bzw. config/dsl.txt definiert worden ist.


RemoteUpdate-Seite

Seite FernUpdate

Diese Seite bietet die Möglichkeit ein Fernupdate auf dem Router einzuspielen. Dabei kann ausgewählt werden, welche vier Programmpakete (Kernel, Rootfilesystem, Opt-File und rc.cfg) auf den Router kopiert werden sollen. Damit man das Update einspielen kann, muss man zuerst mal das fli4l-Verzeichnis angeben, damit Imonc weiss, woher es die nötigen Dateien nehmen soll. Ausserdem muss angegeben werden, in welchem Unterverzeichnis die Konfigurationsdateien liegen, um die Datei opt.tgz jeweils neu zu erzeugen (standardmäßig config). Damit die Möglichkeit besteht, die Konfigurationsdateien mittels FliwizNG zu bearbeiten, muss FliwizNG in das fli4l-Verzeichnis kopiert werden. Ansonsten ist der Button deaktiviert. Es ist ratsam, einen Reboot nach dem Einspielen des Updates durchführen, damit die Änderungen auch direkt wirksam werden. Wird während des Updates nach einem Passwort nachgefragt, ist das root-Passwort gemeint, welches in config/base.txt unter PASSWORD eingetragen ist.


portfw-Seite

Seite Portforwarding

Um die Beschränkung des Portforwarding zu umgehen, dass ein Port nur an genau einen Client-Rechner gebunden ist, besteht die Möglichkeit, die Konfiguration auf dem Router zu editieren. Damit die Änderungen aktiv werden, muss die Verbindung neu hergestellt werden. Da die Datei nur in der Ramdisk ersetzt wird, bleiben die Änderungen nur bis zum nächsten Neustart des Routers erhalten. Um die Änderungen dauerhaft zu speichern, muss eine neue rc.cfg auf dem Router installiert werden mit einer geeignet angepassten config/base.txt.


Files-Seite

Seite Dateien

Diese Seite dient dazu, Konfigurations- und Logdateien des Routers einfach per Maus-Click anzuzeigen. Die Auswahlliste wird über den Punkt Config/Admin und dort "Dateien auf dem Router, die angezeigt werden sollen" konfiguriert. Anschliessend kann einfach über die ComboBox auf dieser Seite ausgewählt werden, welche Datei angezeigt werden soll.


Uptime-Seite

Seite Uptime

Hier ist die Unterstützung für OPT_REGISTER eingebaut. In der Liste ist ersichtlich, welcher Router bereits wielange läuft, welche Fli4l-Version benutzt wird und welchen Nicknamen der Betreiber gewählt hat. Natürlich taucht ein Router nur dann in der Liste auf, wenn der jeweilige Betreiber dies wünscht und dazu OPT_REGISTER installiert hat.


Error-Seite

Seite Fehler

Diese Seite wird nur angezeigt, wenn auch Fehler aufgetreten sind.

Auf der dieser Seite werden sämtliche imonc/imond-spezifischen Fehler festgehalten. Wenn Probleme bestehen, kann unter Umständen ein Blick auf diese Liste die Ursache der Probleme anzeigen.


Syslog-Seite

Seite Syslog

Damit diese Seite angezeigt wird, muss Imonc im Admin-Modus sein und Syslog-Meldungen empfangen haben.

Auf dieser Seite werden die ankommende Syslog-Meldungen angezeigt, bis auf die Meldungen der Firewall. Diese werden auf der eigenen Seite Firewall dargestellt. Damit dies funktioniert, muss die Variable OPT_SYSLOGD in der Konfigurationsdatei config/base.txt auf `yes' gesetzt werden. Ausserdem muss die Variable SYSLOGD_DEST auf die IP des Clients gesetzt werden (genau: SYSLOGD_DEST='@100.100.100.100 - wobei die IP natürlich an die IP des Clients angepasst werden muss). Angezeigt wird neben der eigentlich Syslog-Meldung auch Datum, Uhrzeit, IP des Senders und die Prioritätsstufe.


Firewall-Seite

Seite Firewall

Auch diese Seite wird nur angezeigt, wenn Imonc Meldungen des Paketfilters empfangen hat.

Damit die Meldungen des Paketfilters bei den ganzen Syslog-Meldungen nicht untergehen, werden diese auf dieser separaten Seite angezeigt. Damit die Firewall-Meldungen angezeigt werden können, muss zusätzlich in der Datei config/base.txt die Konfigurationsvariable OPT_KLOGD auf `yes' gesetzt werden.


News-Seite

Seite News

Auf dieser Seite werden, vorausgesetzt die Option ist im Konfig-Bereich des Imonc aktiviert, die News, welche auf der fli4l-Homepage angezeigt werden, auch direkt im Imonc angezeigt werden. Dazu wird mittels http die URL http://www.fli4l.de/german/news.txt abgerufen. Neben den News werden mittlerweile auch die fünf aktuellsten Opt-Pakete angezeigt. Dazu wird auch die URL http://www.fli4l.de/german/imonc_opt_show.php abgefragt. Außerdem wird in der Statusleiste vom Imonc die Überschriften der News alternierend angezeigt.


About-Seite

Seite Über

Neben den Infos zum Imonc können hier die System-Infos als auch die Lizenz des Imonc abgerufen werden.


ConfigGeneral-Seite

Config-Seite Allgemein

  • Aktualisierungsintervall: Hier wird eingestellt, wie oft die Seite Summary aktualisiert werden soll.
  • Zeit beim Programmstart synchronisieren: Übernimmt beim Starten des Imonc-Clients die Zeit und das Datum des Routers als lokale Zeit. Diese Funktion kann auch manuell mit dem Button Synchronize auf der Seite Überblick aufgerufen werden.
  • Minimiert starten: Startet das Programm direkt minimiert, man sieht nur das Icon neben der Uhr.
  • Zusammen mit Windows starten: Hier kann man angeben, ob der Client direkt beim Starten von Windows mit gestartet werden soll. In dem Feld Parameter kann man die nötigen Start-Parameter angeben.
  • News von fli4l.de abholen: Sollen die News, die auf der fli4l-Homepage in der News-Sektion angezeigt werden, auch vom imonc geholt und angezeigt werden? Die Schlagzeilen werden dann in der Statusbar angezeigt. Ausserdem wird dann eine neue Seite News angezeigt, in der die kompletten News angezeigt werden.
  • Logdatei für Anrufe: Den Dateinamen, den man hier angeben kann, wird dazu benutzt, die Anruf-Liste unter diesem Namen lokal auf dem Rechner abzuspeichern. Dieser Menüpunkt ist nur sichtbar, wenn die Config-Variable TELMOND_LOG auf 'yes' gesetzt ist, dieses gilt auch für die eigentliche Anruf-Liste.
  • Logdatei für Verbindungen: dito wie oben nur für die Verbindungen
  • TimeOut für Router zu antworten: Wie lange soll auf eine Antwort der Routers gewartet werden, bevor angenommen wird, dass die Verbindung nicht mehr besteht.
  • Sprache: Hier kann die Sprache des imoncs ausgewählt werden.
  • Router-Befehle bestätigen: Ist dieses Feature aktiviert, müssen alle Router-beeinflussenden Kommandos, wie zum Beispiel Reboot, Hangup usw. generell bestätigt werden.
  • Auflegen auch bei Traffic: Soll kein Hinweis erfolgen, wenn die Verbindung beendet wird und noch Traffic auf der Leitung ist
  • Automatisch Verbindung zum Router aufbauen: Soll, wenn die Verbindung zum Router unterbrochen wird (z.B. durch einen Reboot des Routers), automatisch probiert werden, die Verbindung wieder herzustellen.
  • Fenster schliessen minimiert in den SystemTray: Soll Imonc in den SystemTray minimiert werden, wenn das Imonc-Fenster geschlossen wird.


ConfigProxy-Seite

Config-Seite Proxy

Hier kann ein Proxy für die http-Anfragen des imoncs definiert werden. Dieser wird dann zur Zeit für die beiden Punkte Aktualisierung der Uptime-Tabelle und das Holen der News benutzt.

  • Proxy-Unterstützung für Http-Anfragen aktivieren?: Soll ein Proxy benutzt werden
    • Adresse:Die Adresse des Proxy-Servers
    • Port: Die Portnummer des Proxy-Server (default: 8080)


ConfigCall

Config-Seite Anrufe

Die Position des Call Notification-Fensters wird in der Registry gespeichert, so dass man sich das Fenster an die Position schieben kann, wo man es haben möchte. Es erscheint anschliessend immer wieder an dieser Stelle.

  • Call Notification aktivieren: Bestimmt, ob Anrufe signalisiert werden sollen.
    • Call Notification anzeigen: Soll bei eingehenden Anrufen ein Hinweisfenster mit den Infos: angerufene MSN, Rufnummer des Anrufers und Datum/Uhrzeit erscheinen? Dafür ist es nötig, dass in der Datei config/isdn.txt die Variable OPT_TELMOND auf 'yes' gesetzt wird.
      • Unterdrücken, wenn keine Nummer übertragen wurde: Soll Die CallNotification nicht angezeigt werden, wenn keine Rufnummer übertragen wurde.
      • Sekunden für CallNotification: Diese Angabe beeinflußt die Dauer, wie lange das Call Notification-Fenster geöffnet bleiben soll. Die Angabe von "0" an dieser Stelle bewirkt, dass das Fenster nicht automatisch geschlossen wird.
      • Fontsize: Hiermit wird die Schriftgröße des Call Notification-Fensters bestimmt. Dieses hat Einfluss auf die Größe des Fenster, da die notwendige Größe des Fenster anhand der tatsächlichen Größe der Mitteilung berechnet wird.
      • Farbe: Hiermit kann die Schriftfarbe des Call Notification-Fensters ausgewählt werden. Ich selber benutzte die Farbe rot, damit ich es auch direkt wahrnehme.
  • Führende Null wegen Telefonanlage löschen: Telefonanlage setzen manchmal eine zusätzliche Null vor die Rufnummer des Anrufer. Diese kann mit dieser Option unterdrückt werden.
  • Eigene Vorwahl: Hier kann die eigene Vorwahl hinterlegt werden. Wann dann ein Anruf mit gleichen Vorwahl eintrifft, wird die Vorwahl ausgeblendet.
  • Telefonbuch: Hier die Datei angegeben werden, in der das lokale Telefonbuch zur Auflösung von Telefonnummer gespeichert wird. Existiert die Datei nicht, wird sie vom Programm angelegt.
  • Externes Suchprogramm benutzen: In diesem Bereich kann ein Programm angegeben werden, dass aufgerufen wird, wenn eine Telefonnummer mittels des lokalen Telefonbuches nicht aufgelöst werden kann. Nähere Infos sollten den entsprechenden Programmen beiliegen. Bis jetzt gibt es eine Anbindung an die Telefonbuch-CD KlickTel sowie von Marcel Wappler eine Anbindung an die Palm-Datenbank.


ConfigNames-Seite

Config-Seite Telefonbuch

Diese Seite beinhaltet das Telefonbuch, welches zur Rufnummerauflösung der anrufenden Nummer als auch der eigenen MSN benutzt wird. Die Seite wird auch angezeigt, wenn die Konfigurationsvariable TELMOND_LOG auf 'no' gesetzt ist, da die Rufnummerauflösung auch für die Anzeige des letzten Anrufes auf der Übersicht-Seite benutzt wird. Alternativ kann statt dem Telefonbuch auf dem Router auch eine lokale Datei ausgewählt werden.

Der Aufbau der Eintrag sieht wie folgt aus:

# Format:
# Telefonnummer=anzuzeigender Name[, Wavefilename]
# 0241123456789=Testuser
00=unbekannt
508402=Fax
0241606*=Elsa AG Aachen

Dabei sind die ersten drei Zeilen Kommentare. Die vierte Zeile bewirkt, dass, wenn keine Rufnummer übermittelt wird, "unbekannt" angezeigt wird. In der fünften Zeile wird der MSN 508402 der Name "Fax" zugeordnet. Ansonsten ist das Format immer Telefonnummer=Name, der stattdessen angezeigt werden soll. In der sechsten Zeile ist noch die Möglichkeit demonstriert, eine Sammelrufnummer zu definieren. Damit wird erreicht, dass für alle Nebenstellen von 0241606 der Name angezeigt wird. Zu beachten hierbei ist, dass der erste Eintrag im Telefonbuch, welcher auf den Anruf passt, genommen wird. Optional kann auch noch eine Wave-Datei angegeben werden, die abgespielt wird, wenn ein Telefonanruf von dieser Rufnummer eingeht.

Seit der Version 1.5.2 besteht auch die Möglichkeit das lokale Telefonbuch mit dem auf dem Router abgespeicherten (in /etc/phonebook) zu synchronisieren und umgekehrt. Dabei werden nicht nur einfach die Dateien ersetzt, sondern es werden die noch fehlende Einträge hinzugefügt. Gibt es eine Telefonnummer in beiden Telefonbüchern mit unterschiedlichen Namen, wird nachgefragt, welcher Eintrag genommen werden soll. Für die Synchronisierung des Telefonbuches auf dem Router ist noch anzumerken, dass dieses nur in der Ramdisk verändert wird, d.h. dass nach einem Reboot sämtliche Änderungen verloren gehen.


ConfigSound-Seite

Config-Seite Sound

Die Wave-Dateien, die hier angegeben werden, werden abgespielt, wenn das jeweilige Ereigniss eingetreten ist.

  • EMail: Wenn der EMailChecker auf einem angegebenen POP3-Server EMails vorfindet, wird die angegebene Wave-Datei abgespielt.
  • EMail-Fehler: Wenn ein Fehler beim Abrufen der EMails auftritt, wird diese Wave-Datei abgespielt.
  • Connection Lost: Wenn die Verbindung zum Router nicht mehr vorhanden ist (z.B. wenn der Router von einem anderen Client gerade neu gebootet wird), wird diese Wave-Datei abgespielt. Wenn die Option "Automatisch Verbindung zum Router aufbauen" nicht aktiviert ist, erscheint ausserdem eine MessageBox, die nachfragt, ob versucht werden soll, eine neue Verbindung zum Router aufzubauen.
  • OnConnect: Wenn der Router eine Verbindung zum Internet aufgebaut hat, wird diese Wave-Datei abgespielt.
  • OnDisconnect: Wenn der Router die Verbindung zum Internet wieder abgebaut hat, wird diese Wave-Datei abgespielt.
  • Call Notification: Wenn Show Call Notification aktiviert ist und ein neuer Anruf eingeht, wird die angegebene Wave-Datei abgespielt.


ConfigEMails-Seite

Config-Seite EMails

  • Accounts: Dieser Bereich dient dazu, die vorhandenen POP3-Accounts zu konfigurieren.
  • EMail-Check aktivieren: Soll der EMailChecker automatisch nach neuen EMails suchen
    • Check jede x Min: Hiermit wird angegeben, wie oft der EMailChecker automatisch nach neuen EMails suchen soll.
      Achtung: ein zu kurzes EMailCheckIntervall kann dazu führen, dass der Router komplett online bleibt! Dies ist der Fall, wenn der das EMailCheckIntervall kleiner ist als die hup-timeout des verwendeten Circuits.
    • Timeout: Wie lange soll auf einen einen POP3-Server gewartet werden, bis er antwortet. Der Wert "0" bedeutet, dass kein TimeOut gesetzt wird.
    • Auch wenn Router offline ist: Hiermit wird erreicht, dass der Router sich selbstständig einwählt, um nach EMails zu sehen. Nachdem alle POP3-Konton nach EMails überprüft worden sind, wird die Verbindung wieder getrennt. Um dieses Feature nutzen zu können, muss Dialmode auf 'auto' stehen.
      Achtung: Dadurch entstehen zusätzliche Kosten, wenn nicht gerade eine Flatrate benutzt wird!
      • Zu benutzender Circuit: Hiermit wird angegeben, welcher Circuit zur Einwahl beim EMail-Checken benutzt werden soll.
      • Anschliessend online bleiben: Soll direkt nach dem EMail-Check direkt die Verbindung getrennt werden oder eine Verbindungstrennung durch das Hangup-timeout realisiert werden
    • Email-Header laden: Sollen auch die EMail-Header geladen oder nur die Anzahl der vorhandenen EMails abgefragt werden? Das Laden der EMail-Header ist Voraussetzung, wenn man EMails direkt auf dem Server löschen möchte.
    • Nur neue EMails melden: Sollen nur neue EMails akustisch und mit dem Tray-Icon gemeldet werden
    • EMail-Client starten: Soll der angegebene EMail-Client automatisch gestartet werden, wenn neue EMails vorhanden sind.
      • EMail-Client: Hier wird der zu startende EMail-Client angegeben.
      • Param: Hier kann man zusätzliche Parameter angeben, die beim Start des EMail-Clients übergeben werden sollen. Wenn Outlook als EMail-Client benutzt wird (nicht Outlook Express), sollte /recyle als Parameter eingetragen werden, damit eine bereits geöffnete Instanz von Outlook beim Eintreffen von neuen EMails benutzt wird.


ConfigAdmin-Seite

Config-Seite Admin

  • root-Passwort: Hier sollte das root-Passwort (in config/base.txt unter PASSWORD eingetragen) eingetragen werden, damit z.B. das Forwardingskript portfw.sh lokal bearbeitet und wieder auf dem Router hinterlegt werden kann.
  • Datein auf dem Router, die angezeigt werden sollen: Alle hier angegebenen Dateien, die sich auf dem Router befinden, können einfach per Maus-Click auf der Seite Admin/Dateien angezeigt werden. Somit kann man sich auf einfache Weise die Logfiles des Routers direkt im imonc anzeigen lassen.
  • Konfigdateien bearbeiten: Hier kann ausgewählt werden, ob die Konfigdateien alle im Editor geöffnet werden sollen (dies kann, wenn TXT-Dateien noch mit einem einfachen Editor verknüpft sind, dazu führen, dass sehr viele Instanzen des Editors geöffnet werden). Alternativ kann auch einfach nur das Verzeichnis geöffnet werden, so dass die Möglichkeit besteht, nur die Dateien auszuwählen, die bearbeitet werden sollen.


ConfigLaunchList-Seite

Config-Seite LaunchList

Dieser Bereich dient dazu, die Launchliste zu konfigurieren. Diese wird nach einem erfolgreichen Connect ausgeführt, wenn die Option "Launchlist aktivieren" ausgewählt wurde.

  • Programme: Alle hier eingetragenen Programme werden automatisch gestartet, wenn der Router eine Verbindung aufgebaut hat und die Launchliste aktiviert ist.
  • LaunchList aktivieren: Soll die Launchliste beim erfolgreichen Verbindungsaufbau ausgeführt werden?


ConfigTraffic-Seite

Config-Seite Traffic

Dieser Bereich dient dazu, dass TrafficInfo-Fenster den eigenen Bedürfnissen anzupassen. Von einem User habe ich den Hinweis bekommen, dass es mit älteren DirectX-Versionen offenbar Darstellungsfehler gibt.

  • Separates Traffic-Info-Fenster anzeigen: Soll eine grafische der Kanalauslastung in einem separaten Fenster angezeigt werden? In dem Kontextmenü des Fensters kann man festlegen, ob das Fenster das Attribut StayOnTop bekommen soll. Dieses bewirkt, dass sich das Fenster immer über allen anderen Fenstern plaziert. Auch dieser Wert wird in der Registry abgespeichert und steht somit auch nach einem erneuten Programmstart wieder zur Verfügung.
    • Titelleiste anzeigen: Soll die Titelleiste des Traffic-Info-Fensters angezeigt werden? In der Titelzeile wird angezeigt, mit welchem Circuit der Router gerade online ist.
      • CPU-Auslastung in Titelleiste: Soll auch die CPU-Auslastung in der Titelzeile angezeigt werden?
      • Online-Zeit in Titelleiste: Soll die Onlinezeit des Kanals auch in der Titelzeile angezeigt werden?
    • Semi-transparentes Fenster: Soll das Fenster transparent dargestellt werden? Diese Funktion steht nur unter Windows 2000 und Windows XP zur Verfügung.
    • Farben: Hier werden die Farben für das TrafficInfo-Fenster definiert. Zu Berücksichtigen ist dabei, dass der DSL-Kanal und der erste ISDN-Kanal die selben Farbwerte zugewiesen bekommen.
    • Limits: Hier können die max. Übertragungswerte für DSL eingestellt werden - für T-Online gilt: DSL Upload 128 und DSL Download 768.


ConfigSyslog-Seite

Config-Seite Syslog

Dieser Bereich dient dazu, die Anzeige der Syslog-Meldungen zu konfigurieren.

  • Syslog-Client aktivieren: Sollen Syslog-Meldungen im imonc angezeigt werden? Diese Option sollte ausgeschaltet sein, wenn ein externer Syslog-Client, wie zum Beispiel Kiwi's Syslog Client, benutzt wird.
  • Alle Meldungen ab Stufe anzeigen Ab welcher Prioritätsstufe sollen die Syslog-Meldungen angezeigt werden? Es ist sinnvoll am Anfang mit der Stufe Debug anzufangen, um damit festzustellen, welche Meldungen einen interessieren. Anschliessend kann hier dann die entsprechende Stufe eingetragen werden.
  • Syslog-Meldungen in einer Datei speichern: Sollen die angezeigten Syslog-Meldungen in einer Datei gespeichert werden? In der Groupbox können dann die Meldungen ausgewählt werden, die in der Datei geloggt werden sollen. Für den Dateinamen sind folgende Platzhalter eingefügt worden:
    • %d wird durch den aktuellen Tag ersetzt
    • %m durch den aktuellen Monat
    • %y durch das aktuelle Jahr.
    Beispiel: syslog-%y-%m-%d.txt erzeugt für Syslog-Meldungen am 25.04.2002 eine Logdatei mit dem Namen syslog-2002-04-25.txt
  • Portnamen anzeigen: Sollen statt den Portnummern deren Bedeutung angezeigt werden?
  • Fireall-Meldungen auch im User-Modus zeigen: Hiermit wird festgelegt, ob Firewall-Meldungen auch im User-Modus angezeigt werden sollen.


ConfigFax-Seite

Config-Seite Faxe

Dieser Bereich dient dazu, die Faxanzeige vom imonc zu konfigurieren. Damit dieser Punkt angezeigt wird, muss mgetty oder faxrcvd auf dem Router installiert sein (zu finden als OPT-Pakete auf der fli4l-Homepage).

  • Logdatei für Faxe: Den Dateinamen, den man hier angeben kann, wird dazu benutzt, die Fax-Liste unter diesem Namen lokal auf dem Rechner abzuspeichern.
  • Aktualisierungsintervall: Diese Angabe gibt an, wieoft die Faxübersichtsseite aktualisiert werden soll. Dabei ist zu beachten, dass dieser Wert keine Angabe in Sekunden ist, sondern noch mit der Angabe von Allgemein/Aktualisierungsintervall multipliziert wird. Wenn hier ein Wert von 0 eingetragen wird und ausserdem der Client die Syslog-Meldungen vom Router bekommt, wird kein Polling für die Aktualisierung der Fax-Übersichtsseite betrieben, sondern die Aktualisierung wird durch eine Syslog-Meldung, das ein Fax eingegangen ist, angestossen.
  • Lokales Verzeichnis: Um die Faxe anzeigen zu können, müssen sie lokal gespeichert werden. Dieses kann hier eingestellt werden.


SysInfo-Seite

System-Informationen

Dieser Dialog liefert einige System-Informationen. Ausserdem besteht die Möglichkeit die Support-Infos abzurufen. Dafür muss Imonc sich im Admin-Modus befinden.


SupportInfo-Seite

Support-Infos

Die Support-Infos können bei der Fehlersuche hilfreich sein.


Circuit-Seite

Circuit Config

Hier werden alle konfigurierten Circuits des Routers angezeigt. Der Wert in der Spalte Hup-timeout kann für ISDN-Circuits direkt im StringGrid editiert werden (funktioniert bis dato nicht für DSL).


V1.4.5 Release vom 22.11.00, ist im Paket fli4l V1.4.3 enthalten
  • Bug: Windows lässt sich nicht herunterfahren, wenn imonc läuft (ab V1.4.4)
  • Bug: Absturz von imonc bei falschem EMail-Passwort
  • Bug: PerformanceGraph: Lienen nicht komplett gezeichnet (abruptes auf Null fallen der Lienen)
  • Bug: Nach der Einwahl bleibt auf dem Dial/Hangup-Button die Beschriftung "Dial" und der EMail-Checker wird nicht gestartet
  • Bug: Gelbe-LED in der Taskleiste und die Titel der Application wurde bei einer Anwahl nicht aktualisiert
  • Bug: Fehlermeldung "Ein deaktiviertes oder unsichtbares Fenster kann nicht den Focus erhalten." bei Verwendung des Popupmenüs.
  • Bug: Problem mit Anführungszeichen in Dateinamen für Calls- und Connectionsspeicherung
  • Bug: Es wurden unter gewissen Umständen die gespeicherten Calls und Connection gelöscht
  • Die Möglichkeit das Forwardingskript portfw.sh zu editieren wird nur noch angezeigt, wenn der FTP-Server auf dem Rechner installiert ist.
  • Wenn noch Datenübertragung auf der Leitung stattfindet, gibt es eine Sicherheitsabfrage vor hangup (Damit man jemand anderes nicht unwissend aus der Leitung wirft).
  • Passwörter werden jetzt verschlüsselt in der Registry abgelegt
  • Call Notification: Es erscheint ein kleines Fenster, wenn ein Telefonanruf eingeht, in dem alle wichtigen Infos des Anruf abgelegt sind.
    • Die Position des Fensters wird in der Registry abgespeichert, damit sich jeder das Fenster dorthin positionieren kann, wo er es haben möchte.
    • Die Schriftgröße ist konfigurierbar. Somit kann jeder selber entscheiden, in welcher Größe das Fenster erscheinen soll. Da jetzt die Fenstergröße anhand des benötigten Platzes für die Schrift berechnet wird.
  • Zusätzliches kleines Fenster mit Auslastung der ISDN-Leitung (grafisch und ausserdem die Zahlenwerte)...

    Kann jetzt auch wieder mit beiden Kanälen umgehen (im Gegensatz zur Version 1.5pre1)
  • Bei ankommenden Telefonanrufen oder eingehenden EMails kann jetzt eine Wave-Datei angegeben werden, die dann abgespielt wird.
  • Parameter für den Aufruf des EMail-Clients hinzugefügt, um Mehrfachaufrufe von MS Outlook zu verhindern. (Parameter für MS Outlook lautet: /recycle)
V1.4.4 Release vom 26.10.00, ist im Paket fli4l V1.4.2 / V1.5pre1 enthalten
Benötigt imond ab der Version 1.4.1
  • Bug: Wenn der Router im Netz nicht mehr erreichbar ist (Reboot), erschien eine Fehlermeldung nach der anderen.
  • Bug: Speicherleck korrigiert
  • Hint vom Trayicon ergänzt um die ISDN-Traffic-Werte
  • Es besteht jetzt die Möglichkeit das Forwardingskript portfw.sh auf dem Router zu editieren. Damit kann man die Einschränkung umgehen, dass das Forwarding an einem PC gebunden ist. Damit die Änderungen aktiv werden, muss die Verbindung neu hergestellt werden. Um dieses Feature nutzen zu können, muss der FTP-Server auf dem Router installiert sein.
  • TimeTable wird angezeigt, damit besteht die Möglichkeit das LCR-Verhalten des Routers am Client zu überwachen.
  • EMail-Checker um die Fähigkeit erweitert, mit mehreren EMail-Konten umgehen zu können.
  • Stay On Top-Eigenschaft der Anwendung hinzugefügt
V1.4.3 Release vom 11.10.00, ist im Paket fli4l V1.4.1 enthalten
Benötigt imond ab der Version 1.4.1
  • Bug: Fehlermeldung, wenn der POP-Server nicht erreichbar ist, weggenommen. Stattdessen erscheint jetzt ein durchgestrichenes EMail-Symbol. Durch einen Doppelclick auf das Symbol gelangt man zu den EMail-Einstellungen, um gegebenenfalls die Einstellungen korrigieren zu können.
  • Die Seiten Calls und Connections werden, wenn die Variablen TELMOND_LOG und IMOND_LOG nicht auf "yes" gesetzt sind, ausgeblendet (ebenfalls die dazugehörigen Punkte unter Configuration).
  • Die Sende- und Empfangsrate werden jetzt pro ISDN-Kanal angezeigt (Gelb: Empfangsrate, Rot: Senderate).
  • Sollte der Explorer sich mit einer Schutzverletzung beenden, war das Tray-Icon von imonc verschwunden (auch auf andere Weise konnte man imonc nicht wieder auf dem Bildschirm bekommen). Wenn man jetzt imonc erneut startet, wird die vorherige Instanz von imonc wieder auf den Bildschirm befördert und das Tray-Icon restauriert.
  • Die Position des imonc-Fensters wird in der Registry abgespeichert und beim erneuten Start des Clients benutzt.
  • Calls und Connection werden jetzt direkt nach Änderung abspeichert, nicht erst beim Beenden des Programms.
  • Der EMail-Checker arbeitet jetzt in einem eigenen Thread - Vorteil davon ist, dass das Fenster von imonc direkt erscheint, auch wenn der Router online ist. Es wird also nicht das erste Checken der EMails abgewartet.
V1.4.2 Release vom 07.10.00
Benötigt imond ab der Version 1.4
  • About-Box hinzugefügt
  • EMails-Check implementiert:
    Sobald der Router online ist, werden EMails gecheckt und anschließend im eingestellt Intervall. Sind EMails auf dem POP3-Server vorhanden, wird entweder automatisch der eingestellte EMail-Client gestartet oder ein neues Symbol im Tray neben der Uhr angezeigt, welches als Hint die Anzahl der EMails auf dem Server liefert. Ein Doppelclick startet dann den eingestellten EMail-Client.
    Achtung: ein zu kurzes EMailCheckIntervall kann dazu führen, dass der Router komplett online bleibt!
  • Calls und Connections können lokal gespeichert werden
    In dem Bereich Configuration kann man jetzt für die Dateinamen für die lokale Speicherung der Calls und Connections angeben. Anschließend speichert imonc automatische alle neuen Calls/Connections.
    Damit imond / telmond überhaupt die Calls und Connection loggt, müssen die Configurationsvariablen IMOND_LOG und TELMOND_LOG auf "yes" gesetzt werden.
V1.4.0 Version die mit fli4l V1.4 ausgeliefert wurde


1.5.2patch1b Release vom 12.03.01
Benötigt imond ab fli4l 1.5.2
  • Bug: Synchronisierung mit dem Routertelefonbuch (/etc/phonebook) - Leerzeilen jetzt nicht mehr vorhanden
  • Bug: Startprobleme - Fehlermeldung: Fehler beim Lesen von Memo->Lines.Strings: Fehler beim Einfuegen von Rich-Edit Zeile.
  • Bug: TrayIcon beim Wählen Hellgrün statt Gelb
1.5.2 Release vom 04.03.01
Benötigt imond ab fli4l 1.5.2
  • Bug: Anzeige der TimeTable
  • Bug: Halt-Eintrag im Popupmenü des TrayIcons ohne Funktionalität
  • Bug: Verschlüssungsproblem bei einigen Passwörtern
  • Bug: Variablenüberlauf auf der Connection-Seite bei der Aufsummierung der empfangenen und gesendeten Bytes
  • Anzeige der CPU-Auslastung des Routers
  • Anzeige der gesendeten und empfangenen Bytes auch bei laufenden Verbindungen
  • bessere Erkennung, wann die mktgz.bat komplett abgearbeitet ist (RemoteUpdate)
  • Die Seiten Names und Config/CallNotification werden ausgeblendet, wenn telmond nicht installiert ist
  • Jedem Anrufer kann jetzt eine eigene Wave-Datei zugeordnet werden
  • Zusätzlichen Befehl für den Startparameter /rc eingebaut: dialtimesync. Dieser bewirkt, dass der Router rauswählt und anschliessend wird noch die Zeit synchronisiert.
  • Telefonbuch: statt RTF einfaches Textformat
  • Synchronisierung mit dem auf dem Router abgespeicherten Telefonbuch /etc/phonebook eingebaut
  • Kommunikation (mit imond) in einen eigenen Thread ausgelagert -> deutlich schnellerer Start
  • Mehrere EMails auf einmal direkt auf dem Server löschen
  • TrayIcon um eine weitere Information pro Kanal erweitert: Hellgrün - Traffic auf dem Kanal, Dunkelgrün - so gut wie kein Traffic auf dem Kanal
1.5.1patch1 Release vom 20.02.01
Benötigt imond ab fli4l 1.5 final
  • Bug: EMail-Checker verursacht Verbindungsaufbau, auch wenn die Option "Check even if router is offline" nicht aktiviert ist
  • Titelleiste beim Traffic-Info-Fenster abschaltbar
1.5.1 Release vom 18.02.01
Benötigt imond ab fli4l 1.5 final
  • Bug: Im Usermodus Dialmode nicht änderbar, wenn in der config.txt IMOND_ENABLE auf 'yes' gesetzt war
  • Neuer Startparameter /d : Hiermit kann das fli4l-Verzeichnis übergeben werden.
  • FTP-Port wird jetzt auch in der Systeminfo angezeigt
  • EMail-Accounts deaktivierbar, so dass sie beim EMail-Check nicht berücksichtigt werden (direkt über das Popupmenü anwählbar)
  • Rückfrage bei RESET auf der Calls- und Connection-Seite
V1.5.0patch1 Release vom 12.02.01
Benötigt imond ab fli4l 1.5 final
  • Bug: Synchronize-Button nicht aktiviert
V1.5 Release vom 11.02.01
Benötigt imond ab fli4l 1.5 final
Änderungen in Bezug auf V1.5pre4
  • Bug: Programmsturz wenn einem Soundereignis ein Wave-Datei zugewiesen ist und das Ereignis eintritt, wenn aber keine Soundkarte im Rechner ist.
  • Bug: Leerzeichen im Pfad bei der Autostartfunktion
  • Bug: Bei Voice-Verbindung durch vbox: Annahme Router ist online
  • Unterstützung des User-/Admin-Modus des imond
  • Halt-Button eingefügt, der den Router sauber runterfährt, damit man ihn ausschalten kann
  • EMailChecker um die Möglichkeit erweitert, Mails direkt auf dem Server zu löschen
  • EMailChecker um die Möglichkeit erweitert, selbstständig eine Verbindung ins Internet aufzubauen, wenn der Router gerade nicht online ist (konfigurierbar - default: abgeschaltet).
  • Traffic-Info-Fenster unterstützt jetzt auch DSL
  • Laden der EMail-Header jetzt optional
  • Menüpunkt Dial im Popupmenü des TrayIcons erweitert um die Auswahl der zu benutzenden Circuits
  • Übernehmen der eigenen MSN auf der Calls-Seite ins Telefonbuch
  • imonc angepasst an fliwiz-NG 1.5
  • Neustrukturierte Dokumentation (Kapitel 9.2 der fli4l-Doku)
  • Die Farben des TrafficInfo-Fensters sind jetzt konfigurierbar.
  • Support-Infos werden gesammelt und in der Datei fli4lsup.txt abgespeichert.
  • Fehlermeldung eingebaut, wenn kein Defaultcircuit fürs LCR für den aktuellen Zeitpunkt angegeben ist
  • Punkt 123 der Wunschliste: Im Kontextmenü des traffic-Fenster ein Hangup einzufügen
  • Punkt 129 der Wunschliste: Beim Remote Update einen Name für Config Datei mitgeben, so könnten verschiedene Konfigurationen getestet werden.
V1.5pre4Patch1 Release vom 09.01.01
Benötigt imond ab fli4l V1.5pre4
  • Bug: TrafficInfo: Popup-Menüpunkt "Close" bewirkt nur ein kurzzeitiges schliessen
  • Bug: Die Buttons Minimize und Beenden in der Titelleiste funktionierten nicht (wie erwartet)
  • Bug: Beim Start von imonc wurde probiert, dass Portforwardingskript portfw.sh vom Router zu laden
  • Die About-Seite ein wenig erweitert
V1.5Pre4 Release vom 07.01.01, ist bereits im Paket fli4l V1.5pre4 enthalten
Benötigt imond ab fli4l V1.5pre4
  • Bug: Darstellungsfehler bei großer Schriftgröße beim TrafficInfo-Fenster
  • Bug: "0,00 ist kein gültiger Gleitkommawert"
  • Bug: Zugriffsverletzung beim Start, wenn weder ISDN noch DSL installiert ist
  • Bug: Connection zum Router beim Beenden nicht sauber geschlossen
  • Bug: RemoteUpdate: Wenn die Diskette nicht gemountet war, wurden die Dateien auf die Ramdisk gepackt
  • Bug: Fehler bei Bereichsprüfung (tritt auf bei inkorrektem imond-Logfile)
  • Genaue Analyse des imond-logfiles
  • Übersichtsliste der aufgetretenen Fehler
  • FTP-Port des Routers konfigurierbar
  • Weitere Sound-Ereignisse hinzugefügt: OnConnect, OnDisconnect, EMailError
  • Punkt 006 der Wunschliste: Hup-timeout konfigurierbar (für ISDN-Circuits)
  • Punkt 079 der Wunschliste: Launchliste nach Connect
  • Punkt 085 der Wunschliste: Automatischer Reconnect zum Router, wenn die Verbindung zum Router verlorengegangen ist (abschaltbar)
  • Punkt 097 der Wunschliste: Logfiles anzeigen (konfigurierbar)
V1.5pre3a Release vom 13.12.00, ist im Paket fli4l V1.5pre3a enthalten
Benötigt imond ab fli4l V1.5pre3
  • Bug: Wenn imond keine IP liefert, zeigt imonc nicht alles korrekt an
  • EMail-Log: Sortierreihenfolge geändert, aktuelle Einträge erscheinen jetzt zuerst in der Liste, ein Scrollen ist somit überflüssig
V1.5pre3 Release vom 07.12.00, ist im Paket fli4l V1.5pre3 enthalten
Benötigt imond ab fli4l V1.5pre3
  • Bug: Fehler bei Bereichsüberschreitung
  • Spaltenbreiten der Tabellen Summary, Calls und Connection sind jetzt veränderbar und werden in der Registry gespeichert. Somit kann man die Defaulteinstellungen beispielsweise bei großer Schriftgrößte selber anpassen.
  • Generelle Abfragemöglichkeit (ja/nein) bei Hangup, Reboot und weiteren System-Cmds (generell abgeschaltet)
  • Die gesamte Onlinezeit und die entstandenen Kosten, welche sich in der Logdatei angesammelt haben, werden aufsummiert und auf der Connection-Seite angezeigt
  • Möglichkeit einen Retry für einen Verbindungsaufbau durchzuführen, z.B. nach einem Reboot des Routers
  • Unterstützung des DSL-Circuits
  • EMail-Übersicht: Größe, Subject und Absender werden pro EMail angezeigt
  • Router-Kommandos können per Parameter direkt an den Router übermittelt werden (z.B. hangup als Verknüpfung direkt mit einem Hotkey zugänglich).
  • Portnummern für imond und telmond können angegeben werden
  • Die Seiten Calls und Connection sind etwas überarbeitet
Achtung: Geänderte Parametersyntax! (Siehe imonc-readme)
V1.5pre2 Release vom 20.11.00
benötigt imond ab fli4l V1.5pre2
  • Bug: Keine Fehlermeldungen wenn beim RemoteUpdate FTP-Fehler aufgetreten sind
  • Bug: Fehlermeldung "Ein deaktiviertes oder unsichtbares Fenster kann nicht den Focus erhalten." bei Verwendung des Popupmenüs.
  • Bug: Problem mit Anführungszeichen in Dateinamen für Calls- und Connectionsspeicherung
  • Bug: Es wurden unter gewissen Umständen die gespeicherten Calls und Connection gelöscht
  • Traffic Info wieder um den zweiten Kanal erweitert
  • Bei ankommenden Telefonanrufen oder eingehenden EMails kann jetzt eine Wave-Datei angegeben werden, die dann abgespielt wird.
  • Parameter für den Aufruf des EMail-Clients hinzugefügt, um Mehrfachaufrufe von MS Outlook zu verhindern. (Parameter für MS Outlook lautet: /recycle)
  • Call Notification erweitert um die folgenden Punkte:
    • Die Position des Fensters wird in der Registry abgespeichert, damit sich jeder das Fenster dorthin positionieren kann, wo er es haben möchte.
    • Die Schriftgröße ist konfigurierbar. Somit kann jeder selber entscheiden, in welcher Größe das Fenster erscheinen soll. Da jetzt die Fenstergröße anhand des benötigten Platzes für die Schrift berechnet wird.
V1.5pre1 Release vom 11.11.00, ist im Paket fli4l V1.5pre2 enthalten
Änderungen in Bezug auf V1.4.4
  • Bug: Windows lässt sich nicht herunterfahren, wenn imonc läuft (ab V1.4.4)
  • Bug: Absturz von imonc bei falschem EMail-Passwort
  • Bug: PerformanceGraph: Lienen nicht komplett gezeichnet (abruptes auf Null fallen der Lienen)
  • Bug: Nach der Einwahl bleibt auf dem Dial/Hangup-Button die Beschriftung "Dial" und der EMail-Checker wird nicht gestartet
  • Bug: Gelbe-LED in der Taskleiste und die Titel der Application wurde bei einer Anwahl nicht aktualisiert
  • Die Möglichkeit das Forwardingskript portfw.sh zu editieren wird nur noch angezeigt, wenn der FTP-Server auf dem Rechner installiert ist.
  • Wenn noch Datenübertragung auf der Leitung stattfindet, gibt es eine Sicherheitsabfrage vor hangup (Damit man jemand anderes nicht unwissend aus der Leitung wirft).
  • Zusätzliches kleines Fenster mit Auslastung der ISDN-Leitung (grafisch und ausserdem die Zahlenwerte)...
  • Möglichkeit bei installiertem FTP-Server ein Fernupdate des Routers durchzuführen
  • Ausnutzung des Versions-Befehls von imond, um Versionskonflikten zwischen imond und imonc aus dem Weg zu gehen.
  • Passwörter werden jetzt verschlüsselt in der Registry abgelegt
  • Call Notification: Es erscheint ein kleines Fenster, wenn ein Telefonanruf eingeht, in dem alle wichtigen Infos des Anruf abgelegt sind.


1.6.3patch2 Release vom 08.11.01
Benötigt imond ab fli4l 1.6.3patch1
  • Bug: Connection-Logfile teilweise nicht automatisch angezeigt
  • Bug: Anrufliste beim Start nicht angezeigt
  • Bug: Fernupdate wurde nicht auf den Router übertragen, wenn die Festplatte "geparkt" war
  • Bug: EMailCheck - Option "Anschliessend online bleiben" verkehrt interpretiert
  • Bug: Im Opendialog der Launchliste wurden keine Programme angezeigt
  • Versteht jetzt auch das Connect-Logfileformat vom imond 2.0 Final
1.6.3patch1 Release vom 15.10.01
Benötigt imond ab fli4l 1.6.3patch1
  • Bug: Erkennung, ob ein Kanal online ist, war fehlerhaft
  • Fernupdate: Erzeugung von opt.tgz und rc.cfg beschleunigt
1.6.3 Release vom 10.10.01
Benötigt imond ab fli4l 1.6.2
  • Bug: Fehlermeldung nach Neubooten des Routers
  • Bug: Fehler beim Löschen von Faxen, die noch auf dem Router sind
  • Bug: Telefonbuchsynchronisierung mit dem Router im Usermodus verfügbar
  • Bug: Darstellungsfehler in der ersten Spalte der TimeTable, wenn der Circuit-Index >=10 war
  • Bug: Anrufe auf die VBOX als Datenverbindungen angenommen
  • Bug: Dateianzeige von 0 Byte grossen Dateien
  • Vor dem Standby-Modus von Windows wird die Kommunikation zum imond sauber beendet und nachher wieder neu aufgebaut
  • Support-Infos um die Ausgabe von ifconfig -all erweitert
  • Beim Fernupdate werden Fehlermeldungen von mktgz.bat jetzt in einer MessageBox angezeigt
  • Zusätzlicher Commandline-Parameter: /NoStartCheck Dieser schaltet die Überprüfung ab, ob imonc bereits läuft. Nur sinnvoll, wenn mehrere, unterschiedliche fli4l-Router in einem Netz überwacht werden sollen. Bei weiteren Instanzen werden die eingebauten Syslog- und EMail-Funktionalitäten deaktiviert.
1.6.2patch1 Release vom 19.07.01
Benötigt imond ab fli4l 1.6.2
  • Bug: Beim Senden von Dateien an den Router würde nach dem Passwort gefragt, wenn die Datei nicht angelegt werden konnte
  • Bug: diverse kleinere
1.6.2 Release vom 15.07.01
Benötigt imond ab fli4l 1.6.2
  • Bug: Reboot des Routers wurde vom imonc nicht erkannt (seit 1.6.1patch1)
  • Bug: Wenn das Traffic-Info-Fenster über das Kontextmenü des Fensters geschlossen wurde, wurde es im Kontextmenü des TrayIcons noch als aktiv gekennzeichnet
  • Generelle Abfrage vor dem Halt-Befehl
  • Fernupdate benutzt nicht mehr den FTP-Server auf dem Router
  • Zusätzlicher Commandline-Parameter: /wait - Wenn der Hostname nicht aufgelöst werden kann, beendet sich imonc nicht mehr - erneuter Verbindungsaufbau durch Doppelclick auf das TrayIcon
  • Unterstützung für das OPT-Paket mgetty eingebaut - siehe auch Wunschliste 251
  • Wunschliste 220: Uptime des Routers wird auf der Überblicksseite angezeigt
  • Wunschliste 248: Die "Check Now"-Option im Kontextmenü von imonc sollte auch ohne bestehende Verbindung funktionieren (d.h. erst eine Verbindung aufbauen), so daß man schnell nachschauen kann ob E-Mail da ist. - Allerdings muss dafür Dialmode auf auto stehen.
  • Wunschliste 274: In der Timetable farbige Kennzeichnung der einzelnen Circuits
1.6.1patch1 Release vom 14.06.01
Benötigt imond ab fli4l 1.6.0
  • Bug: Im Kontextmenü des TrayIcons sind die Circuits nach einem Reboot des Routers nicht korrekt eingetragen
  • Bug: Calls-Ansicht beim Start u.U. nicht aktualisiert
  • Bug: Rufnummer wurde bei Einwahl nicht angezeigt
  • Bug: Dateiname für Syslog-Logdatei nicht auswählbar
  • Bug: Absturz des imonds nach dem Beenden vom imonc
  • Bug: Auf der Summary-Seite Variablenüberlauf bei Datenmengen grösser ca. 2GB
  • Portnummer in der Firewall-Anzeige wird jetzt durch die Bedeutung des Ports ersetzt, konfigurierbar
  • Unterstützung für FliStat von Stefan Böhm eingebaut
1.6.1 Release vom 09.05.01
Benötigt imond ab fli4l 1.6.0
  • Bug: Popupmenü im TrafficInfo-Fenster erschien nicht
  • Bug: Wenn im fli4l-Verzeichnisnamen ein Leerzeichen vorgekommen ist, funktionierte das RemoteUpdate für das Opt-File nicht mehr
  • Bug: Firewall-Meldungen wurden nicht korrekt geloggt
  • Bug: Wenn ein anderer Syslog-Client bereits lief, hat sich imonc mit einer Fehlermeldung einfach beendet (wenn die entsprechende Option im imonc eingeschaltet war)
  • Bug: Telefonbuch auf dem Router wurde nicht synchronisiert
  • Wenn keins oder ein falsches FTP-Passwort gesetzt ist, kommt jetzt eine Abfrage, wo man es direkt eintragen kann
  • Syslog und Firewall-Meldungen werden nur im Admin-Modus angezeigt
  • Der Bereich TimeTable ist nur noch im Admin-Modus verfügbar
  • Bei der Telefonbuchsynchronisierung mit externer Datei wird diese angelegt, wenn sie noch nicht existiert
  • Telmond-Kommunikation in einen eigenen Thread ausgelagert
  • Eingebauter Syslog-Client: Es kann jetzt ausgewählt werden, welche Meldungen in der Datei geloggt werden sollen
  • Konfigurationsbereich in ein eigenes Fenster ausgelagert
  • Die Seite Namen in den Konfigbereich rübergeschoben und umgenannt in Telefonbuch
  • Wunschliste 166: 1.) Ausblenden der führenden 0 beim Betrieb an einer Telefonanlage 2.) Ausblenden der eigenen Vorwahl
  • Wunschliste 194: Doppelklick auf das "Traffic-Fenster" öffnet Hauptfenster vom Imonc
  • Wunschliste 198: EMail-Abfrageintervall von max 99 Minuten auf maximal 9999 erhöht
1.6.0 Release vom 25.03.01
Benötigt imond ab fli4l 1.6.0
  • Bug: Problem mit telmond nach SuspendToRam
  • Auch für MSNs können jetzt Wave-Dateien angegeben werden. Diese wird abgespielt, wenn für den Anrufer selber keine spezielle Wave-Datei angegeben worden ist.
  • imonc vorbereitet auf Sprachmodule (einfache Textdateien, die die Übersetzungen beinhalten)
  • Gezielter Hangup einzelner Kanäle möglich über Kontextmenü auf der Summary-Seite
  • Eingebauter Syslog-Client
  • Log der Firewall wird aufbereitet
  • Traffic-Info-Fenster jetzt auch ohne Titelleiste verschiebbar
  • Hilfe eingebaut (verweiste auf die HTML-Dokumentation)
  • Telefonbuch auch mit lokaler Datei synchronisierbar (und umgekehrt)


2.0.7f Release vom 25.08.04
Benötigt imond ab fli4l 2.0.4
  • Bug: einige Passwörter sind nach dem Speichern in die Registry nicht mehr korrekt entschlüsselt worden. (25.08.04)
2.0.7e Release vom 17.05.04
Benötigt imond ab fli4l 2.0.4
  • Weiterer Bug im Newsbereich
2.0.7d Release vom 26.10.03
Benötigt imond ab fli4l 2.0.4
  • Bug: Im Newsbereich
2.0.7c Release vom 27.02.03
Benötigt imond ab fli4l 2.0.4
  • Bug: Imonc löst beim Beenden eine erneute Einwahl aus, wenn die News-Option aktiviert ist
2.0.7b Release vom 02.02.03
Benötigt imond ab fli4l 2.0.4
  • Bug: Im "Logging" der tmp-Dateien im News-Bereich
2.0.7a Release vom 01.02.03
Benötigt imond ab fli4l 2.0.4
  • Bug: Im Newsbereich (betrifft Version 2.0.7)
  • Die beiden angelegten temporären Dateien für den News-Bereich werden jetzt "gelockt", so dass sie nicht mehr versehentlich gelöscht werden können.
2.0.7 Release vom 08.12.02
Benötigt imond ab fli4l 2.0.4
  • Bug: Spaltenbreite bei den Meldungen des Packetfilters wurden nicht gespeichert.
  • Bug: Eintrag des Traffic-Info-Fenster in der Taskleiste, wenn keine Titelzeile angezeigt wird - seit Version 2.0.5 vorhanden
  • Zusätzliche Option beim Startparameter /rc:"timesync" - synchronisiert die Uhrzeit des Clients mit der des Routers. Deshalb ist dialtimesync rausgenommen worden, da durch "dial;timesync" ersetzbar
  • News-Bereich aus der 2.1er Serie übernommen.
2.0.5 Release vom 16.09.02
Benötigt imond ab fli4l 2.0.4
  • Bug: Es liesen sich Werte kleiner 1024 für DSL Down- bzw. Upload eintragen, was zu Fehlermeldungen "Division durch Null" führte
  • Unterstützung der Windows-Themes (Luna)
  • Variable für Aktualisierung der Faxanzeige vergrößert
  • Neues Imonc-Icon von Thilo Mauser
  • StayOnTop verbessert - Dank einem Tip von Achim Kalwa
2.0.4 Release vom 10.05.02
Benötigt imond ab fli4l 2.0.2 (zumindest für das Fernupdate, sonst 2.0)
  • Bug: Bei Großbuchstaben in den Startparametern /rc bzw. /NoStartCheck
  • Bug: Die Einstellung LaunchList aktiviert wurde nicht abgespeichert
  • Fehlermeldung eingebaut, falls kein geeigneter Bildbetrachter für die Faxdateien installiert ist
  • Imonc wurde von Guido Clauw ins Niederländische übersetzt
  • Multi-Monitor-Support verbessert
2.0.3 Release vom 23.02.02
Benötigt imond ab fli4l 2.0.2 (zumindest für das Fernupdate, sonst 2.0)
  • Bug: Timeout-Probleme beim Übertragen von Listen (Anruf-, Verbindungs-, Faxliste oder Support Infos)
  • Bug: Config-Dialog: Problem mit Leerzeichen im Pfad von Logdateien bei Anruf-, Verbindungs- oder Faxlog
  • Bug: Großbuchstaben im Passwort wurden beim Startparameter /p: in die entsprechenden Kleinbuchstaben konvertiert
  • Bug: Einige Syslog-Meldungen sind verworfen worden
  • Bug: Wenn imonc mit dem Startparameter /s:ip gestartet worden ist und der Router nicht eingeschaltet war, hat sich imonc nicht mehr beenden lassen
2.0.2 Release vom 09.02.02
Benötigt imond ab fli4l 2.0.2 (zumindest für das Fernupdate, sonst 2.0)
  • Bug: Im Opendialog der Launchliste wurden keine Programme angezeigt
  • Bug: EMailChecker hat abgebrochen, nachdem ein Fehler aufgetreten ist
  • Bug: englische Übersetzung der Remoteupdate-Seite noch auf altem Stand (1.x)
  • Bug: Befehl dialtimesync für den Startparameter /rc funktionierte nicht
  • Bug: Syslog-Level sind falsch angegeben worden im Syslog-Client
  • Root-Passwort wird nicht mehr standardmäßig abgespeichert
  • Routername wird nur noch beim Start in die zugehörige IP aufgelöst. Damit beendet sich imonc nicht mehr, wenn der Kontakt zum Router (und DNS-Server) verloren geht
  • Abfrage, ob die Leitung geschlossen werden soll, wenn noch Traffic drauf ist, ist abschaltbar
  • EMail-Client wird immer in dem Verzeichnis ausgeführt, in dem auch die aufgerufene Startdatei liegt
  • Auswahl, ob die Konfig-Dateien im Editor geöffnet werden sollen oder nur das Verzeichnis angezeigt wird
  • Den zusätzlichen Title-Button entfernt, dafür minimiert der Minimiert-Button imonc in den System-Tray. Somit erscheint auch das Hauptfenster vom imonc im XP-Style unter Windows XP.
  • Deutsches Sprachfile wird automatisch ausgewählt, wenn in Windows die deustche Sprache ausgewählt wurde und das Sprachfile vorhanden ist
2.0.1 Release vom 04.11.01
Benötigt imond ab fli4l 2.0
  • Bug: Fernupdate wurde nicht auf den Router übertragen, wenn die Festplatte "geparkt" war
  • Bug: EMailCheck - Option "Anschliessend online bleiben" verkehrt interpretiert
  • Kontextmenü war nicht übersetzt worden
  • Fernupdate: Router-Verzeichnis fest auf /boot eingestellt
  • Timer, der den Wählen-Button wieder aktiviert (nach 30 Sekunden)
2.0 Release vom 20.10.01
Benötigt imond ab fli4l 2.0 Final
Änderungen in Bezug auf Version 2.0pre3
  • Bug: Dateianzeige von 0 Byte grossen Dateien
  • Bug: Wenn in Dateinamen von Soundfiles eckige Klammern vorkommen, wurde der Config-Dialog nicht geöffnet
  • Bug: Maximieren des Fensters war deaktiviert
  • Bug: Circuitnamen die mit OK oder ERR beginnen, führen zum Absturz des imoncs
  • Bug: Erkennung, ob ein Kanal online ist, war fehlerhaft
  • Fernupdate: Erzeugung von opt.tgz und rc.cfg beschleunigt
  • Optimierung der von imond übertragenen Daten - bei Kanälen, die gerade offline sind, werden 3 Informationen weniger angefordert - Danke fü den Tip Stefan
  • Dekodierung von kodierten EMail-Headern in der EMail-Übersicht
2.0pre3 Release vom 30.09.01
Benötigt imond ab fli4l 2.0pre3
  • Bug: Reboot des Routers wurde vom imonc nicht erkannt (seit 2.0pre1patch1)
  • Bug: Wenn das Traffic-Info-Fenster über das Kontextmenü des Fensters geschlossen wurde, wurde es im Kontextmenü des TrayIcons noch als aktiv gekennzeichnet
  • Bug: Darstellungsfehler in der ersten Spalte der TimeTable, wenn der Circuit-Index >=10 war
  • Bug: Anrufe auf die VBOX als Datenverbindungen angenommen
  • Vor dem Standby-Modus von Windows wird die Kommunikation zum imond sauber beendet und nachher wieder neu aufgebaut
  • Startparameter /rc erweitert: es können mehrere Befehle auf einmal geschickt werden, z.B. /rc:"hangup;halt"
  • Generelle Abfrage vor dem Halt-Befehl
  • Fernupdate benutzt nicht mehr den FTP-Server auf dem Router
  • Zusätzlicher Commandline-Parameter: /wait - Wenn der Hostname nicht aufgelöst werden kann, beendet sich imonc nicht mehr - erneuter Verbindungsaufbau durch Doppelclick auf das TrayIcon
  • Zusätzlicher Commandline-Parameter: /NoStartCheck Dieser schaltet die Überprüfung ab, ob imonc bereits läuft. Nur sinnvoll, wenn mehrere, unterschiedliche fli4l-Router in einem Netz überwacht werden sollen. Bei weiteren Instanzen werden die eingebauten Syslog- und EMail-Funktionalitäten deaktiviert.
  • Fenster ist größenveränderbar
  • Support-Infos um die Ausgabe von ifconfig -all erweitert
  • Beim Fernupdate werden Fehlermeldungen von mktgz.bat jetzt in einer MessageBox angezeigt
  • Unterstützung für das OPT-Paket mgetty eingebaut - siehe auch Wunschliste 251
  • Wunschliste 220: Uptime des Routers wird auf der Überblicksseite angezeigt
  • Wunschliste 248: Die "Check Now"-Option im Kontextmenü von imonc sollte auch ohne bestehende Verbindung funktionieren (d.h. erst eine Verbindung aufbauen), so daß man schnell nachschauen kann ob E-Mail da ist. - Allerdings muss dafür Dialmode auf auto stehen.
  • Wunschliste 274: In der Timetable farbige Kennzeichnung der einzelnen Circuits
  • Wunschliste 289: Traffic-Info sollte eine manuelle Eingabe der maximalen Up- und Downloadgeschwindigkeit anbieten, um bei DSL den 16KB Upstream auch auf 100% Messhöhe anzeigen zu lassen oder einer schnelleren/langsameren Leitung anzupassen.
  • Wunschliste 292: Schön wäre es, wenn der Imonc beim E-Mail-Check sich nur mit dem E-Mail-Symbol meldet, wenn man neue Nachrichten hat, da einige die Nachrichten als Kopie auf dem Server belassen.
  • Wunschliste 333: Wäre es möglich bei der call-notification optional nur sounds abzuspieln ohne ein pop-up fenster, da dies z.b. beim spielen sehr praktisch wäre
  • Wunschliste 335: Super würde ich es finden wenn man auch Sammelnummern im Telefonbuch benutzen könnte z.B. 123456*=Firma ABCD
2.0pre1patch1 Release vom 14.06.01
Benötigt imond ab fli4l 1.6.0
  • Bug: Dateiname für Syslog-Logdatei nicht auswählbar
  • Bug: Absturz des imonds nach dem Beenden vom imonc
  • Bug: Auf der Summary-Seite Variablenüberlauf bei Datenmengen grösser ca. 2GB
  • Unterstützung für FliStat von Stefan Böhm eingebaut
  • Auflösung der Portnummern in der Firewall-Anzeige jetzt konfigurierbar
2.0pre1 Release vom 17.05.01
Benötigt imond ab fli4l 1.6.0
Änderungen in Bezug auf Version 1.6.1
  • Bug: Calls-Ansicht beim Start u.U. nicht aktualisiert
  • Bug: Rufnummer wurde bei Einwahl nicht angezeigt
  • Bug: Im Kontextmenü des TrayIcons sind die Circuits nach einem Reboot des Routers nicht korrekt eingetragen
  • Anpassung an das 2.0er Dateisystem für das Fernupdate des Routers
  • Portnummer in der Firewall-Anzeige wird jetzt durch die Bedeutung des Ports ersetzt


2.1.13 Release vom 06.12.05
Benötigt imond ab fli4l 2.1.13
  • Anpassung an Änderungen von OPT_FAXRCV (06.12.05)
2.1.11a Release vom 07.11.05
Benötigt imond ab fli4l 2.1.10
  • Horizontale Einteilung der Newsseite wird gespeichert (06.09.05)
  • Bug: Absturz beim Beenden, wenn Telmond verwendet wird (06.09.05)
  • Bug: Absturz beim Umschalten der Anrufabfrage (06.09.05)
  • Bug: Erster Anruf nach dem Programmstart wurde bei Capi2Text und Syslog nicht angezeigt (06.09.05)
  • Bug: In der Call-Notification wurden zwei Nullen gelöscht (11.10.05)
  • Bug: Komische Reaktionen anderer Programme, bei eingehenden Anrufen (11.10.05)
2.1.11 Release vom 20.07.05
Benötigt imond ab fli4l 2.1.10
  • Bug: Kontextmenü auf der Zusammenfassungsseite deaktiviert (13.06.05)
  • Bug: Nullpointer-Exception, wenn die Hostliste während des Updates geschlossen worden ist (19.07.05)
  • Bug: 'Application seems to be frozen' nach Fernupdate/Reconnect (19.07.05)
  • Bug: Im Kontextmenü des TrayIcons war eine Circuitauswahl nicht möglich (19.07.05)
2.1.10a Release vom 13.06.05
Benötigt imond ab fli4l 2.1.10
  • Fernupdate: Rootfs wurde nicht gefunden wegen Namensänderung in fli4l (13.06.05)
2.1.10 Release vom 12.06.05
Benötigt imond ab fli4l 2.1.10
  • Config-Dialog/Anrufe: Punkt wird nicht mehr ausgeblendet, wenn Telmond nicht erreichbar -> Umschalten auf Syslog oder Capi2Text möglich (28.03.05)
  • Seite Admin/Uptime deaktiviert (28.03.05)
  • News von net(t)work(s) e.V. hinzugefügt (28.03.05)
  • News-Seite: Einzelne Newsquellen werden fett hervorgehoben (30.03.05)
  • Refactoring der Telmond-Abfrage (14.05.05)
  • Umstellung auf Borland C++ Builder 6 (23.05.05)
  • Benutzung der madExcept-Komponente, sowie JVCL-Komponentenbibliothek (24.05.05)
  • Aktualisierung der ICS-Komponente (28.05.05)
2.1.9a Release vom 01.02.05
Benötigt imond ab fli4l 2.1.9 mit mindestens Patch 1
  • Bug: Wenn beim Fernupdate build\mkfli4l_error.flg existiert, aber nicht build\mkfli4l_error.log. (17.01.05)
  • Bug: Wenn es Einträge in der Launchlist gab, beendete sich Imonc mit einer Fehlermeldung. (26.01.05)
  • Bug: Probleme bei großer Systemschrift ("large fonts") - Spalten wurden mit jedem Imonc Start immer etwas breiter. (26.01.05)
  • Bug: Imonc stürtzt bei eingehenden Anrufen ab, wenn Telmond aktiviert ist aber kein Log geschrieben wird. (26.01.05)
  • Auf die Firewall-Seite werden jetzt alle Syslog-Meldungen angezeigt, die mit "kernel: fw-" beginnen. (26.01.05)
  • Korrektes Parsen der ICMP-Firewallmeldungen - in QPort wird der Type angezeigt und in ZPort der Code. (26.01.05)
  • Unterstützung für capi2text auf einem eisfair-Rechner. (26.01.05)
2.1.9 Release vom 16.01.05
Benötigt imond ab fli4l 2.1.9 mit mindestens Patch 1
  • Der Dialmode kann als Hintergrundfarbe des TrayIcons angezeigt werden. (18.11.04)
  • Korrekte Auswertung des Exitcodes von mkfli4l.bat. (03.12.04)
  • Anpassungen beim Fernupdate. (19.12.04)
2.1.8d Release vom 15.11.04
Benötigt imond ab fli4l 2.1.8
  • Bug: Fehler beim News-Holen. (15.11.04)
2.1.8c Release vom 11.11.04
Benötigt imond ab fli4l 2.1.8
  • Verzeichnisauswahl-Dialog renoviert. (23.09.04)
  • Bug: Portforwarding mit Portranges wurden angemeckert. (24.09.04)
  • Bug: Logdatei vom Syslog entält nur Sonderzeichen statt Uhrzeit und Datum. (29.09.04)
2.1.8b Release vom 21.09.04
Benötigt imond ab fli4l 2.1.8
  • Bug: Faxe werden nicht angezeigt. (13.09.04)
  • Bug: Das älteste Fax bzw. Anruf wurden nicht angezeigt. (21.09.04)
  • Bug: In der Verbindungsübersicht waren Start- und Endzeit identisch. (21.09.04)
2.1.8a Release vom 13.09.04
Benötigt imond ab fli4l 2.1.8
  • Code für FliWiz rausgenommen. (12.09.04)
  • Fernupdate restrukturiert. (12.09.04)
  • Bug: Fehlermeldung, dass kein Default-Circuit existiert, kommt nur noch einmal. (12.09.04)
  • Bug: Exception beim Verlust der Verbindung zum imond. (13.09.04)
  • Bug: Imonc hängt nach Fernupdate, Reconnect funktioniert nicht, imonc hängt wenn der Router nicht direkt gefunden wurde. (13.09.04)
2.1.8 Release vom 09.09.04
Benötigt imond ab fli4l 2.1.8
  • Wird als Transparenzwert 255 für das Traffic-Fenster ausgewählt, wird die Transparenzfunktionalität nicht benutzt. (04.05.04)
  • Aktualisierung der Anrufmitteilung jetzt auch per Syslog-Meldung des telmonds möglich. (04.05.04)
  • Warnung für FernUpdate des Rootfs rausgenommen (da nicht mehr nötig). (08.06.04)
  • Syslinux.cfg aktualisierbar per Fernupdate. (14.06.04)
  • Bug: Abnormal Program Termination bei Verwendung des Startparameters /rc (21.06.04)
  • Alle Datums- und Zeitangaben werden gemäß den Einstellungen in der Systemsteuerung formatiert. (21.06.04)
  • Bug: Ein an die Taskleiste angedocktes Traffic-Fenster veränderte seine Position nach einem Neustart. (24.06.04)
  • Anruf-Seite: Die Nummer des Anrufers wird auch im Kontext-Menü angezeigt (um beispielsweise zurückrufen zu können). (24.06.04)
  • Eingehende Anrufe werden der Liste hinzugefügt, ohne die komplette Liste neu aufzubauen. (02.07.04)
  • Refactoring der Anruf- und Faxliste. (07.07.04)
  • Kommentarspalte bei Anrufe und Faxe eingefügt. (07.07.04)
  • Minimieren des Imonc-Fenster und der X-Button verwenden selben Code. (09.07.04)
  • Imonc verhielt sich während der Abfrage von Daten des imonds träge. (11.07.04)
  • Bug: Teilweise wurden die Einstellungen der Admin-Seite nicht korrekt gespeichert und stattdessen "Null"-Werte. (11.07.04)
  • Host-Seite unter Admin hinzugefügt. (24.08.04)
  • Möglichkeit bei eingehenden Faxen einen Sound abzuspielen eingefügt. (25.08.04)
  • Bug: einige Passwörter sind nach dem Speichern in die Registry nicht mehr korrekt entschlüsselt worden. (25.08.04)
  • Fernupdate angepasst (rootfs.gz wird durch mkopt erzeugt). (09.09.04)
2.1.7a Release vom 27.07.04
Benötigt imond ab fli4l 2.1.7
  • Uptime-Server umgestellt auf register.fli4l.net (05.07.04)
2.1.7 Release vom 02.05.04
Benötigt imond ab fli4l 2.1.7
  • Fernupdate-Seite überarbeitet und fli4l 2.1.7 angepasst (12.04.04)
  • Überblick-Seite überarbeitet: Platzierung von OPT_REGISTER wird angezeigt (15.04.04)
  • Neuer Farbauswahl-Button im Konfigurationsdialog (18.04.04)
  • Bug: Exception beim Beenden vom ImonC (29.04.04)
  • Bug: im Konfig-Dialog wurden die Einstellungen von den Grids nicht gespeichert (30.04.04)
2.1.6 Relase vom 06.03.04
Benötigt imond ab fli4l 2.1.3
  • Einstellungen werden auch beim Beenden des Config-Dialogs in der Registry gespeichert (18.02.04)
  • Durchwahlen von Anlagenanschlüssen können jetzt auch in der Anrufliste übernommen werden, um einen Telefonbucheintrag zu erstellen (03.03.04)
  • Bug: Speicherleck (News-Holen) (05.03.04)
2.1.5 Release vom 02.01.04
Benötigt imond ab fli4l 2.1.3
  • EMail-Icon wird zurückgesetzt, wenn das EMail-Log zurückgesetzt wird (17.10.03)
  • Auch bei NEW_FW_CONFIG werden jetzt die Firewallmeldungen korrekt angezeigt (17.10.03)
  • Refactoring weiter vorangetrieben (17.10.03)
  • Im Telefonbuch können jetzt Programme angegeben werden, die ausgeführt werden, wenn die entsprechende Nummer anruft bzw. die entsprechende Nummer angerufen wurde. Dabei werden die folgenden Parameter die durch aktuellen Werte ersetzt: %p Nummer des Anrufers, %m MSN, %d Datum und %t Uhrzeit. (18.10.03)
  • Bug: Zeilenumbrüche beim Synchronisieren des Telefonbuches mit dem Router (18.10.03)
  • TrayIcon wird automatisch erzeugt und die Farben sind jetzt konfigurierbar. (18.10.03)
  • Bug: Im Newsbereich (26.10.03)
  • Anpassung an die Bzip2-Komprimierung des Rootfs (02.12.03)
  • Newsbereich komplett überarbeitet - das neu eingerichtete RDF-Format wird jetzt benutzt. (03.12.03)
  • Zur aktuelle Meldung auf den Seiten Syslog, Firewall und Fehler wird automatisch hingescrollt. (21.12.03)
2.1.4b Release vom 07.10.03
Benötigt imond ab fli4l 2.1.3
  • Bug: Exception beim Start von imonc (Telmond auf dem Router aktiv, aber ohne Logs zu speichern) (07.10.03)
2.1.4a Release vom 05.10.03
Benötigt imond ab fli4l 2.1.3
  • Bug: Exception, wenn der Config-Dialog geöffnet wird (05.10.03)
  • Bug: Exception nach Reboot, wenn Faxunterstüzung auf dem Router läuft (05.10.03)
  • Bug: Exception bei Tabelle kopieren bei Anrufen & Faxen (05.10.03)
  • Bug: Bei Rufnummerübernehmen wird nur der Config-Dialog geöffnet, ohne auf die passende Seite zu wechseln (05.10.03)
  • Komponente CoolTrayIcon upgedated auf 4.3.1 (05.10.03)
2.1.4 Release vom 17.09.03
Benötigt imond ab fli4l 2.1.3
  • Kommunikation mit dem imond auf dem Router optimiert (10.08.03)
  • Bug: Fernupdate bei Festplatteninstallation vom Typ A bzw. bei Disketteninstallation funktionierte nicht (Fehler beim Löschen von /boot/opt.old) (13.08.03)
  • root-Passwort wird über die Session gespeichert, auch wenn es nicht in der Registry gespeichert werden soll (somit muss es beim Fernupdate nicht immer wieder eingegeben werden) (18.08.03)
  • Unterstützung für die Logfile-Abfrage von dynEisfair (25.08.03)
2.1.3 Release vom 22.07.03
Benötigt imond ab fli4l 2.1.3
  • Bug: Auswahl, was in der Logdatei gespeichert werden soll, beim Syslog nicht auswählbar
  • Die Anzeige der CallNotification kann unterdrückt werden, wenn keine Rufnummer übertragen wurde
  • Verschlüsselte Übertragung des imond-Passwortes
  • Tabellen - wie Anrufliste, Firewallmeldungen usw. - können in die Zwischenablage kopiert werden
  • Vernünftige Fehlermeldungen, wenn etwas beim FernUpdate schief läuft
  • Reboot-CheckBox beim Fernupdate rausgenommen (18.06.)
  • Bug: Reconnect zum Router wurde nicht sauber signalisiert (18.06.)
  • EMail löschen auf dem Server in einen eigenen Thread ausgelagert (07.07.03)
2.1.2c Release vom 27.02.03
Benötigt imond ab fli4l 2.1.1
  • Bug: Bei Reconnect wurde ein geöffnetes Traffic-Fenster nicht geschlossen -> mehrere Traffic-Fenster
  • Bug: Anruf-Seite wurde im Config-Bereich einige Sekunden nach dem Start vom imonc zur Auswahl angeboten, obwohl kein ISDN installiert ist
  • Bug: Imonc löst beim Beenden eine erneute Einwahl aus, wenn die News-Option aktiviert ist
  • Es können jetzt auch Dateien >64kb im Admin-Bereich angezeigt werden
2.1.2b Release vom 04.02.03
Benötigt imond ab fli4l 2.1.1
  • Auch die Breite der News-Header wird gespeichert
2.1.2a Release vom 01.02.03
Benötigt imond ab fli4l 2.1.1
  • Bug: Nach Standby des Rechners mehrere Traffic Info-Fenster
  • Bug: Im Newsbereich
  • Die beiden angelegten temporären Dateien für den News-Bereich werden jetzt "gelockt", so dass sie nicht mehr versehentlich gelöscht werden können.
  • Meldungen des Packetfilters iptable werden nun korrekt angezeigt.
  • Spalten des News-Grids werden gespeichert
2.1.1 Release vom 23.12.02
Benötigt imond ab fli4l 2.1.1
  • Bug: die Proxy-Unterstützung funktionierte bei der Uptime-Aktualisierung nicht
  • Aktualisierung der Fax-, Verbindungs- und Anruf-Seite refactored
  • angepasst an neuen Strukturen des imonds für übertragene Datenmengen
  • Vor einem Reboot des Routers kommt immer eine Nachfrage - analog zum halt-Befehl
  • Support-Infos ein wenig erweitert
  • News-Seite erweitert: die fünf aktuellen Opt-Pakete werden angezeigt
  • Timer eingeführt für den Add-Button, da beim Scheitern der manuellen Kanalbündelung der Button nicht wieder aktiviert wurde
  • Tastatursteuerung optimiert
  • ToolTip des TrayIcons auf KB/s umgestellt
  • Fenster der Call-Notification grundlegend neu designed - inspiriert vom TrayFlow-Imonc
  • Hilfedatei erzeugt
  • Zusätzliche Option beim Startparameter /rc:"timesync" - synchronisiert die Uhrzeit des Clients mit der des Routers. Deshalb ist dialtimesync rausgenommen worden, da durch "dial;timesync" ersetzbar
  • Genereller Exception-Handler eingebaut mit Abfrage, ob Imonc weiterlaufen soll. Ausserdem wird Logfile imonc.err geführt.
  • EMail-Checker-Thread re-designed.
  • Einstellbare Verzögerung beim EMail-Check eingebaut, wenn der Router online geht.
  • Startparameter /log re-designed.
  • Die Eisfair-News werden auch in den News angezeigt.
  • Spaltenausrichtung der StringGrids überarbeitet.
  • Bessere Unterstützung für große Schriftgrößen.
  • Anpassungen an Portforwarding, die durch Änderungen an /etc/portfw.conf nötig wurden.
2.1.0 Release vom 27.07.02
Benötigt imond ab fli4l 2.1.0
läuft nur mit fli4l >=2.1.0 !
  • Bug: Die Einstellung LaunchList aktiviert wurde nicht abgespeichert
  • Traffic-Bereich überarbeitet (unter der Oberfläche)
  • Das Holen der News von fli4l.de in einen Thread ausgelagert - somit deutlich schnellerer Start, wenn der Router online ist
  • Das Holen der Uptime ebenfalls in einen Thread ausgelagert
  • Firewall-Meldungen können jetzt auch im User-Modus angezeigt werden
  • Die Faxanzeige kann auch per Syslog-Meldungen aktualisiert werden, anstatt in einem einstellbaren Rythmus zu pollen (dafür Aktualisierungsintervall beim Fax auf 0 stellen und die Syslog-Meldungen an den Client weiterleiten)
  • Imonc wurde von Guido Clauw ins Niederländische übersetzt, ergänzt durch Ghost
  • Multi-Monitor-Support verbessert
  • Uptime-Tabelle: Ausnutzen der neuen imond-Unterstützung
  • Unterstützung der Windows-Themes (Luna)
  • Syslog-Anzeige: ^M am Zeilenende unterdrückt
  • Http-Proxy-Unterstützung
  • Gelöschte Faxe auf dem Client landen im Papierkorb und werden nicht mehr hart gelöscht
  • Traffic-Info-Fenster schnappt sich nicht mehr den Fokus, wenn es geöffnet wird (weil der Router sich eingewählt hat)
  • Den Bereich Admin/Portforwarding an fli4l 2.1 angepasst
  • StayOnTop verbessert - Dank einem Tip von Achim Kalwa
2.1.0 BETA Release vom 26.04.02
Benötigt imond ab fli4l 2.0.3
Änderungen in Bezug auf Version 2.0.3
  • Bug: Bei Großbuchstaben in den Startparametern /rc bzw. /NoStartCheck
  • Fehlermeldung eingebaut, falls kein geeigneter Bildbetrachter für die Faxdateien installiert ist
  • Variable für Aktualisierung der Faxanzeige vergrößert
  • EMail-Abruf intern komplett überarbeitet - komplette Subject-Anzeige und sichereres Löschen von Mails auf dem Server durch Ausnutzung der MessageID (sofern vorhanden)
  • interne Umstrukturierung der Behandlung von Kanälen - einfacheres Erweitern für neue Kanäle wie Modem oder Trennung von pptp und pppoe
  • Bei allen StringGrids können jetzt im Konfigdialog die Spalten ausgewählt werden, die angezeigt werden sollen
  • Die Einträge der Verbindungs-, Anruf- und Faxübersicht können eingeschränkt werden - z.B. nur die Verbindungen des aktuellen Monats werden angezeigt
  • Exportieren der Konfiguration in eine Reg-Datei, die dann per Doppelclick installiert werden kann (Achtung: Passwörter sind ebenfalls in der Reg-Datei enthalten)
  • Unterstützung für externe Programme zur Namensauflösung von Telefonnummern eingebaut - dazu gibt es von mir als Zusatzprogramm TeleCD, welches auf die Daten der KlickTel zugreifen kann (mittels RufIdent und NrZuName.dll - beide werden nicht mitgeliefert)
  • Komplett überarbeitete Farbgestaltung für die Traffic-Anzeige
  • Bei der Syslog und Firewall-Anzeige wird jetzt auch die IP des Absenders angezeigt
  • Für die Logdatei vom Syslog ist es jetzt möglich Platzhalter in dem Dateinamen vorzugeben - %d für den Tag, %m für den Monat und %y für das Jahr
  • Unterstützung für OPT_REGISTER
  • Position des lokalen Telefonbuch jetzt variabel
  • Unterstützung von absoluten Pfaden für den Faxempfang in mfax.log
  • Fernupdate: ein auf dem Router vorhandenes /boot/opt.old wird vor der Übertragung von opt.tgz gelöscht
  • In der Anrufliste wird die anrufende Telefonnummer als Hint angezeigt, wenn statt der Nummer ein Name in der Anzeige erscheint
  • News-Seite komplett überarbeitet
  • Wunschliste 343: Bei den Seiten Firewall, Syslog und Error stehen jetzt auch die aktuellen Einträge oben
  • Wunschliste 290: Es wär für Nicht-Flatler praktisch, wenn im Traffic-Fenster von Imonc die Zeit, die man schon online ist angezeigt wird.


3.0.0 Release vom 24.12.05
Benötigt imond ab fli4l 2.1.13
  • Update der madExecpt Komponente auf Version 3.0a (14.12.06)
  • Bug: Kopieren der IP in die Zwischenablage auf der Überblick-Seite funktionierte nicht (19.12.06)
  • Die von fli4l für jedes Netzwerkinterface erzeugten Einträge in der hosts-Datei werden nicht mehr auf der Hosts-Seite angezeigt (19.12.06)
  • Zusätzliche fli4l/imonc-Informationen werden einem Bug Report hinzugefügt (19.12.06)
  • Anpassung an die Änderungen der News-Feeds von fli4l.de und eisfair.org (21.12.06)
  • Anzeige der fünf aktuellsten Opt-Pakete wegen Umstellung der Webseite deaktiviert (22.12.06)


Imonc-Lizenz

Lizenzvertrag

Die nachfolgenden Bedingungen, nachstehend "EULA" (End User License agreement) genannt, sind für die Benutzungslizenz zwischen Ihnen und dem Autor von Imonc massgeblich. Mit der Benutzung von Imonc erklären Sie sich mit den Bedingungen dieser Lizenzvereinbarung einverstanden.

Die Bedingungen gelten für die vorliegende Software:
Imonc, nachgeladene Daten, Hilfen,Bildschirmmasken oder mitgelieferte elektronische Handbücher. Wenn Sie Imonc installieren, kopieren oder anderweitig nutzen, erklären Sie sich mit vorliegendem EULA einverstanden. Sind Sie nicht einverstanden, dürfen Sie das Software Produkt nicht installieren oder anderweitig benutzen.

  1. Lizenzbedingungen

    • Weitergabe der Software:
      Sie dürfen das Programm im Rahmen privater Nutzung frei kopieren und verwenden.

  2. Die Lizenz beinhaltet folgende weitere Rechte und Pflichten

    • Keine Verwendung einzelner Dateien:
      Es ist Ihnen nicht gestattet, einzelne Dateien aus dem Paket für eine Verwendung in anderen Produkten oder Umgebungen zu entfernen bzw. zu isolieren.
    • Keine Weiterveräußerung:
      Es ist Ihnen untersagt, das Software Produkt zu verkaufen, zu verleasen, oder anderweitig entgeltlich weiterzugeben. Es ist ebenfalls nicht gestattet, beim Verkauf anderer Gegenstände/Software dieses Software-Produkt kostenlos beizulegen.
      Der Autor behält sich eine straf- und/oder zivilrechtliche Verfolgung vor.
    • Support Service:
      Der Autor garantiert Ihnen für das Programm Imonc keinen Support. Sofern Nachrichten, Rückmeldungen oder Materialien von Ihnen an den Autor zugesandt werden, steht es dem Autor frei, diese zu beantworten bzw. zurückzusenden.

  3. Urheberrechte

    • Software und Begleitmaterial:
      Soweit nicht ausdrücklich durch dieses EULA überlassen, verbleiben alle Rechte am Software-Produkt und den gedruckten Begleitmaterialien beim Autor des Programms. Das Software-Produkt und die Begleitmaterialien sind urheberrechtlich geschützt.
    • WWW-Verlinkung
      Das Landgericht Hamburg hat mit einem Urteil vom 12. Mai 1998 entschieden, dass man durch die Anbringung eines Links die Inhalte der gelinkten Seite gegebenenfalls mit zu verantworten hat, wenn man sich nicht ausdrücklich von den Inhalten der verlinkten Seite distanziert. Imonc bietet auch Links zu anderen Seiten im Internet. Für alle in Imonc verwendeten Links gilt:
      • Der Autor hat keinerlei Einfluss auf die Gestaltung und die Inhalte dieser Seiten.
      • Der Autor überwacht keine Links auf Korrektheit und Beständigkeit.
      • Der Autor distanziert sich von den auf den verlinkten Seiten dargestellten Inhalten und macht sich die Inhalte nicht zu Eigen.
      • Es gelten die Copyrightbedingungen auf der verlinkten Seite.

  4. Datenschutz

    Der Autor garantiert, dass keine personenbezogen Daten erhoben ermittelt oder weitergegeben werden.

  5. Gewährleistung und Haftungsbegrenzungen

    DIESE SOFTWARE UND DIE DAZUGEHÖRIGEN DATEIEN WERDEN "WIE VORLIEGEND" ANGEBOTEN. ES WIRD KEINERLEI GARANTIE ÜBERNOMMEN. Da diese Software in unterschiedlicher Hard- und Softwareumgebung zum Einsatz kommt, WIRD KEINERLEI GARANTIE FÜR DIE GEBRAUCHSFÄHIGKEIT ABGEGEBEN.

    Erfahrene Benutzer neuer Software testen dieses Programm sinnvollerweise zuerst an Probedaten, bevor Sie sich vollends darauf verlassen. Der Benutzer übernimmt das volle Risiko bei Benutzung der Software.

    DER AUTHOR ÜBERNIMMT KEINERLEI GARANTIEN UND KEINE VERANTWORTUNG FÜR DATENVERLUSTE, ENTGANGENE GEWINNE ODER SONSTIGE SCHÄDEN, DIE IHNEN BEIM GEBRAUCH DER SOFTWARE ENTSTEHEN KÖNNTEN. SIE BENUTZEN DAS PROGRAMM AUF EIGENE GEFAHR!

    Der Autor HAFTET ebenfalls NICHT für leichte Fahrlässigkeit.

  6. Schlussvereinbarung

    Die Installation und der Gebrauch von Imonc bedeutet ein Akzeptieren der Lizenzbestimmungen. Es gilt das Recht der Bundesrepublik Deutschland. Gerichtsstand ist, soweit nicht anders vereinbart, Aachen.